summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2020-03-29 23:23:14 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-17 08:29:02 +0100
commiteb029c9ac0f5820c05912760a95388827a6d3f0d (patch)
tree2b6b63beeb8b1cc03f430bfbeeb9d7f12de66869 /meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb
parent782cde184e1e04279d727e3ce78bc34ce6cf1243 (diff)
downloadpoky-eb029c9ac0f5820c05912760a95388827a6d3f0d.tar.gz
lttng-modules: update to 2.10.14
Upgrade to version 2.10.14 in order to fix some build errors with latest 5.4 kernel. - conflicting types for 'trace_rcu_dyntick' Reproductible on kernel greater than v5.4.22, starting with commit 6cf539a87a ("rcu: Fix data-race due to atomic_t copy-by-value") Also drop patches which are no longer required. (From OE-Core rev: 88cce1d9d06ed4c5a7b58a31d75cfd1503605df9) Signed-off-by: Marek Vasut <marex@denx.de> Cc: Armin Kuster <akuster808@gmail.com> Cc: Daniel Dragomir <Daniel.Dragomir@windriver.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb b/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb
new file mode 100644
index 0000000000..1c24e94902
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.10.14.bb
@@ -0,0 +1,46 @@
1SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4LICENSE = "LGPLv2.1 & GPLv2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \
6 file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
7 file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \
8 "
9
10inherit module
11
12COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm|riscv).*-linux'
13
14SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
16 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
17 "
18
19SRC_URI[md5sum] = "3e9ed67a2da17edf93194f8a5e75a246"
20SRC_URI[sha256sum] = "d0ba614a9cac3daf8ac034837f8b786e6be2ce0242aeecef7096bed5e03b762c"
21
22export INSTALL_MOD_DIR="kernel/lttng-modules"
23
24EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
25
26do_install_append() {
27 # Delete empty directories to avoid QA failures if no modules were built
28 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
29}
30
31python do_package_prepend() {
32 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
33 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
34}
35
36BBCLASSEXTEND = "devupstream:target"
37LIC_FILES_CHKSUM_class-devupstream = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3"
38DEFAULT_PREFERENCE_class-devupstream = "-1"
39SRC_URI_class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.10 \
40 file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
41 file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
42 "
43SRCREV_class-devupstream = "b34304f146ea234ea764580d7ce1b03d05a215f9"
44PV_class-devupstream = "2.10.14+git${SRCPV}"
45S_class-devupstream = "${WORKDIR}/git"
46SRCREV_FORMAT ?= "lttng_git"