diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-06-01 17:03:07 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2023-06-02 15:16:35 +0100 |
commit | 7c88bb07001f2b45a5129dc2efd514d3d7e7ea15 (patch) | |
tree | b232f15fc9e5e11fad57f46492d10b18578b3824 /meta/recipes-kernel/lttng/babeltrace2_2.0.5.bb | |
parent | 37a7a24d0c7856a79eebd09192a14d7c1c9df82a (diff) | |
download | poky-7c88bb07001f2b45a5129dc2efd514d3d7e7ea15.tar.gz |
babeltrace2: upgrade 2.0.4 -> 2.0.5
Changelog:
==========
* bt2: honor build system compiler/linker preferences
* Fix: clear_string_field(): set first character to 0
* Fix: src.ctf.fs: Not resolving event common ctx
* debug-info: fix -Wenum-int-mismatch problem in copy_field_class_content_internal
* fix: pass exec-prefix to python bindings install
* fix: document proper Bison version requirement
* cli: use return value of g_string_free
* babeltrace2-query(1): erroneous parameter used in example
* Fix: tests: print real values in a fixed format
* Fix: bt2: autodisc: remove thread error while inserting status in map
* tests: src.ctf.fs: add test for metadata with invalid syntax
* tests: shorten names of session-rotation trace
* bt2: ignore -Wredundant-decls warning
* ctf: fix -Wformat-overflow error in ctf-meta-resolve.cpp
* ctf-writer: fix -Wformat-overflow errors in resolve.c
* Fix: src.text.details: use write_uint_prop_value to handle unsigned values in write_int_range
* Add `dev-requirements.txt` for pip
* Fix: src.ctf.lttng-live: consider empty metadata packet as retry
* Fix: ctf: wrongfully requiring CTF metadata signature for every section
* Fix: src.ctf.lttng-live: session closed before any metadata is received
* fix: obsolete warnings with autoconf >= 2.71
* fix: explicitly disable '-Wsuggest-attribute=format'
* fix: set stable branch in gitreview config
* Fix: ctf-writer: list of reserved keywords
* compiler warning cleanup: is_signed_type: compare -1 to 1
* Update working version to Babeltrace 2.0.5
(From OE-Core rev: ae47b6c2a4bdee031d42687582049c15614faa6d)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/babeltrace2_2.0.5.bb')
-rw-r--r-- | meta/recipes-kernel/lttng/babeltrace2_2.0.5.bb | 94 |
1 files changed, 94 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/babeltrace2_2.0.5.bb b/meta/recipes-kernel/lttng/babeltrace2_2.0.5.bb new file mode 100644 index 0000000000..6123456c30 --- /dev/null +++ b/meta/recipes-kernel/lttng/babeltrace2_2.0.5.bb | |||
@@ -0,0 +1,94 @@ | |||
1 | SUMMARY = "Babeltrace2 - Trace Format Babel Tower" | ||
2 | DESCRIPTION = "Babeltrace provides trace read and write libraries in host side, as well as a trace converter, which used to convert LTTng 2.0 traces into human-readable log." | ||
3 | HOMEPAGE = "http://babeltrace.org/" | ||
4 | BUGTRACKER = "https://bugs.lttng.org/projects/babeltrace" | ||
5 | LICENSE = "MIT & GPL-2.0-only & LGPL-2.1-only & BSD-2-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a458c13f18385b7bc5069a6d7b176e" | ||
7 | |||
8 | DEPENDS = "glib-2.0 util-linux popt bison-native flex-native" | ||
9 | |||
10 | SRC_URI = "git://git.efficios.com/babeltrace.git;branch=stable-2.0;protocol=https \ | ||
11 | file://run-ptest \ | ||
12 | file://0001-tests-do-not-run-test-applications-from-.libs.patch \ | ||
13 | file://0001-Make-manpages-multilib-identical.patch \ | ||
14 | " | ||
15 | SRCREV = "66e76d1ea601705928899138f02730a3a2a3153d" | ||
16 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>2(\.\d+)+)$" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | inherit autotools pkgconfig ptest python3targetconfig | ||
21 | |||
22 | EXTRA_OECONF = "--disable-debug-info --disable-Werror" | ||
23 | |||
24 | PACKAGECONFIG ??= "manpages" | ||
25 | PACKAGECONFIG[manpages] = ", --disable-man-pages, asciidoc-native xmlto-native" | ||
26 | |||
27 | FILES:${PN}-staticdev += "${libdir}/babeltrace2/plugins/*.a" | ||
28 | FILES:${PN} += "${libdir}/babeltrace2/plugins/*.so" | ||
29 | |||
30 | ASNEEDED = "" | ||
31 | |||
32 | # coreutils since we need full mktemp | ||
33 | RDEPENDS:${PN}-ptest += "bash gawk python3 make grep coreutils findutils" | ||
34 | |||
35 | do_compile_ptest () { | ||
36 | make -C tests all | ||
37 | } | ||
38 | |||
39 | do_install_ptest () { | ||
40 | install -d "${D}${PTEST_PATH}/tests" | ||
41 | |||
42 | # Copy required files from source directory | ||
43 | for d in $(find "${S}/tests" -type d -printf '%P ') ; do | ||
44 | install -d "${D}${PTEST_PATH}/tests/$d" | ||
45 | find "${S}/tests/$d" -maxdepth 1 -executable -type f \ | ||
46 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} + | ||
47 | find "${S}/tests/$d" -maxdepth 1 -name *.sh \ | ||
48 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \; | ||
49 | find "${S}/tests/$d" -maxdepth 1 -name *.py \ | ||
50 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \; | ||
51 | find "${S}/tests/$d" -maxdepth 1 -name *.expect \ | ||
52 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \; | ||
53 | done | ||
54 | install -d "${D}${PTEST_PATH}/tests/data/ctf-traces/" | ||
55 | cp -a ${S}/tests/data/ctf-traces/* ${D}${PTEST_PATH}/tests/data/ctf-traces/ | ||
56 | |||
57 | # Copy the tests directory tree and the executables and | ||
58 | # Makefiles found within. | ||
59 | install -D "${B}/tests/Makefile" "${D}${PTEST_PATH}/tests/" | ||
60 | for d in $(find "${B}/tests" -type d -not -name .libs -printf '%P ') ; do | ||
61 | install -d "${D}${PTEST_PATH}/tests/$d" | ||
62 | find "${B}/tests/$d" -maxdepth 1 -executable -type f \ | ||
63 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} + | ||
64 | test -r "${B}/tests/$d/Makefile" && \ | ||
65 | install -t "${D}${PTEST_PATH}/tests/$d" "${B}/tests/$d/Makefile" | ||
66 | find "${B}/tests/$d" -maxdepth 1 -name *.sh \ | ||
67 | -exec install -t "${D}${PTEST_PATH}/tests/$d" {} \; | ||
68 | done | ||
69 | |||
70 | for d in $(find "${B}/tests" -type d -name .libs -printf '%P ') ; do | ||
71 | for f in $(find "${B}/tests/$d" -maxdepth 1 -executable -type f -printf '%P ') ; do | ||
72 | cp ${B}/tests/$d/$f ${D}${PTEST_PATH}/tests/`dirname $d`/$f | ||
73 | done | ||
74 | done | ||
75 | |||
76 | # Prevent attempts to update Makefiles during test runs, and | ||
77 | # silence "Making check in $SUBDIR" messages. | ||
78 | find "${D}${PTEST_PATH}" -name Makefile -type f -exec \ | ||
79 | sed -i \ | ||
80 | -e '/Makefile:/,/^$/d' \ | ||
81 | -e '/%: %.in/,/^$/d' \ | ||
82 | -e '/echo "Making $$target in $$subdir"; \\/d' \ | ||
83 | -e 's/^srcdir = \(.*\)/srcdir = ./' \ | ||
84 | -e 's/^builddir = \(.*\)/builddir = ./' \ | ||
85 | -e 's/^all-am:.*/all-am:/' \ | ||
86 | {} + | ||
87 | |||
88 | # Substitute links to installed binaries. | ||
89 | install -d "${D}${PTEST_PATH}/src/cli/" | ||
90 | ln -s "${bindir}/babeltrace2" ${D}${PTEST_PATH}/src/cli/ | ||
91 | |||
92 | # Remove architechture specific testfiles | ||
93 | rm -rf ${D}${PTEST_PATH}/tests/data/plugins/flt.lttng-utils.debug-info/* | ||
94 | } | ||