summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng-2.0/lttng-ust_2.1.0.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2013-01-11 17:28:47 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-16 11:57:32 +0000
commit44a485f7a6eff41523a1a37526021c01ec75daef (patch)
tree04f0feea69942b4c1e971bb33a33c34eb8a9ac1a /meta/recipes-kernel/lttng-2.0/lttng-ust_2.1.0.bb
parent4a5ad289d1826957cd22ae9af36bbd127b4816b0 (diff)
downloadpoky-44a485f7a6eff41523a1a37526021c01ec75daef.tar.gz
lttng2-ust: rename to lttng-ust
recipes-kernel/lttng/lttng-ust was removed by a previous patch, which also removed the naming conflict that caused the lttng-2.0 version of lttng-ust to be named lttng2-ust. lttng2-ust was the only lttng-2.0 recipe to be named in this way and since that was entirely due to the conflict, we can go back to the consistent naming for it. (From OE-Core rev: 3c927c39502061bdf3ef9fba1f0f6e7080f6c3cd) Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng-2.0/lttng-ust_2.1.0.bb')
-rw-r--r--meta/recipes-kernel/lttng-2.0/lttng-ust_2.1.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng-2.0/lttng-ust_2.1.0.bb b/meta/recipes-kernel/lttng-2.0/lttng-ust_2.1.0.bb
new file mode 100644
index 0000000000..1076bde574
--- /dev/null
+++ b/meta/recipes-kernel/lttng-2.0/lttng-ust_2.1.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.0"
2DESCRIPTION = "The LTTng UST 2.0 package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/lttng2.0"
4BUGTRACKER = "n/a"
5
6LICENSE = "LGPLv2.1+ & BSD & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools
12
13DEPENDS = "liburcu util-linux"
14
15# For backwards compatibility after rename
16RPROVIDES_${PN} = "lttng2-ust"
17RREPLACES_${PN} = "lttng2-ust"
18RCONFLICTS_${PN} = "lttng2-ust"
19
20SRCREV = "0c9ad44b7604040dfcd1e67b18afc3dc5d025b19"
21PV = "2.1.0"
22PR = "r0"
23
24SRC_URI = "git://git.lttng.org/lttng-ust.git;protocol=git"
25
26S = "${WORKDIR}/git"
27
28do_configure_prepend () {
29 ${S}/bootstrap
30}
31
32# Due to liburcu not building for MIPS currently this recipe needs to
33# be limited also.
34# So here let us first suppport x86/arm/powerpc platforms now.
35COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|powerpc.*)-linux.*'