summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-01-11 11:58:26 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-18 11:47:03 +0000
commite9280d13a88701500ffdcb9ba51abeb5c322ca0d (patch)
tree34fdaae0fe88ea86ee602f7d9c80c7ccff255ed6 /meta/recipes-kernel/linux/linux-yocto_4.4.bb
parent8c3276ecea38d4d67c22e6db49060b2d4b457278 (diff)
downloadpoky-e9280d13a88701500ffdcb9ba51abeb5c322ca0d.tar.gz
linux-yocto: introduce v4.4 standard/preempt-rt/standard kernel
The 4.4 kernel has been under test via linux-yocto-dev, and is the next LTS/LTSI kernel. So we take our -dev support and created a named/versioned recipe for use in upcoming releases. (From OE-Core rev: 2dbc788bc3988532f0932e8e51e24ba702c28f6a) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.4.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.4.bb b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
new file mode 100644
index 0000000000..a440cf7b26
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_4.4.bb
@@ -0,0 +1,42 @@
1KBRANCH ?= "standard/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# board specific branches
6KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
7KBRANCH_qemuarm64 ?= "standard/qemuarm64"
8KBRANCH_qemumips ?= "standard/mti-malta32"
9KBRANCH_qemuppc ?= "standard/qemuppc"
10KBRANCH_qemux86 ?= "standard/base"
11KBRANCH_qemux86-64 ?= "standard/base"
12KBRANCH_qemumips64 ?= "standard/mti-malta64"
13
14SRCREV_machine_qemuarm ?= "bcfc111e6c14b9f9d6ffa9d357651c0b4489835e"
15SRCREV_machine_qemuarm64 ?= "2dadc3524fcbce0c46f5db65b7c20c673fc60503"
16SRCREV_machine_qemumips ?= "9d9c37432e75eaeb2232e00cc3c2252440b709b3"
17SRCREV_machine_qemuppc ?= "2dadc3524fcbce0c46f5db65b7c20c673fc60503"
18SRCREV_machine_qemux86 ?= "2dadc3524fcbce0c46f5db65b7c20c673fc60503"
19SRCREV_machine_qemux86-64 ?= "2dadc3524fcbce0c46f5db65b7c20c673fc60503"
20SRCREV_machine_qemumips64 ?= "cb3a85329501f541ebfa08febb2f36edcbc6f253"
21SRCREV_machine ?= "2dadc3524fcbce0c46f5db65b7c20c673fc60503"
22SRCREV_meta ?= "ad9d3f01300ba350563e17db00b2518302e172f6"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;name=machine;branch=${KBRANCH}; \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
26
27LINUX_VERSION ?= "4.4"
28
29PV = "${LINUX_VERSION}+git${SRCPV}"
30
31KMETA = "kernel-meta"
32KCONF_BSP_AUDIT_LEVEL = "2"
33
34COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
35
36# Functionality flags
37KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
38KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
39KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
40KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
41KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
42KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"