summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.19.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-12-16 22:38:23 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-18 16:19:34 +0000
commit5cc1a7ceccfc61a5a574934da6c39dfc4e3a108b (patch)
treea491d41d85e6dba6b413b8be514cef24623dc4d3 /meta/recipes-kernel/linux/linux-yocto_4.19.bb
parentb701df379e62c0ef25d884191c782088df811fa5 (diff)
downloadpoky-5cc1a7ceccfc61a5a574934da6c39dfc4e3a108b.tar.gz
linux-yocto: introduce 4.19 recipes
Introduce the 4.19 linux kernel as the reference for LTS and eventually LSB distros. For now, we keep the other versions around until the h/w reference BSPs are updated and 4.20+ are available as the "latest" kernel. This avoid updating qemu* to 4.19 as the default for a small transition window. (From OE-Core rev: d52d68adff8fc2b9b2a98405f57fb06d2ed26c24) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.19.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.19.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.19.bb b/meta/recipes-kernel/linux/linux-yocto_4.19.bb
new file mode 100644
index 0000000000..815c92b93a
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_4.19.bb
@@ -0,0 +1,48 @@
1KBRANCH ?= "v4.19/standard/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# board specific branches
6KBRANCH_qemuarm ?= "v4.19/standard/arm-versatile-926ejs"
7KBRANCH_qemuarm64 ?= "v4.19/standard/qemuarm64"
8KBRANCH_qemumips ?= "v4.19/standard/mti-malta32"
9KBRANCH_qemuppc ?= "v4.19/standard/qemuppc"
10KBRANCH_qemux86 ?= "v4.19/standard/base"
11KBRANCH_qemux86-64 ?= "v4.19/standard/base"
12KBRANCH_qemumips64 ?= "v4.19/standard/mti-malta64"
13
14SRCREV_machine_qemuarm ?= "a14b08c3446dfab88ff97d84a9ba70db11287290"
15SRCREV_machine_qemuarm64 ?= "ba6690e7b65aaa1d1030e51498aaf2c5eb7e88b1"
16SRCREV_machine_qemumips ?= "69975293fac754567a3ebdd0aa914d461e218b70"
17SRCREV_machine_qemuppc ?= "ba6690e7b65aaa1d1030e51498aaf2c5eb7e88b1"
18SRCREV_machine_qemux86 ?= "ba6690e7b65aaa1d1030e51498aaf2c5eb7e88b1"
19SRCREV_machine_qemux86-64 ?= "ba6690e7b65aaa1d1030e51498aaf2c5eb7e88b1"
20SRCREV_machine_qemumips64 ?= "8c14832341502679afbfb370d48b977ecf363c82"
21SRCREV_machine ?= "ba6690e7b65aaa1d1030e51498aaf2c5eb7e88b1"
22SRCREV_meta ?= "f7bff5bff6ef6ceadfb4661a6ef3ed1f95bd6b2b"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"
26
27LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
28LINUX_VERSION ?= "4.19.5"
29
30DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
31DEPENDS += "openssl-native util-linux-native"
32
33PV = "${LINUX_VERSION}+git${SRCPV}"
34
35KMETA = "kernel-meta"
36KCONF_BSP_AUDIT_LEVEL = "2"
37
38KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
39
40COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
41
42# Functionality flags
43KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
44KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
45KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
46KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
47KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
48KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"