summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-03-06 13:11:13 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-26 15:07:11 +0100
commit7cc677aa4f6f9bdcaa6137b47b16b6161626c0d3 (patch)
treebe8bfcf08e7815ce60711f38c1930945c190ee20 /meta/recipes-kernel/linux/linux-yocto_4.12.bb
parent67ddcc4a306fe50da5e8527935b6fc02b94ff74e (diff)
downloadpoky-7cc677aa4f6f9bdcaa6137b47b16b6161626c0d3.tar.gz
linux-yocto/4.12: fix aufs compile warning
From: "Kexin(Casey) Chen" <Casey.Chen@windriver.com> Forward port linux-yocto-4.8's patch to fix the build warning. http://git.yoctoproject.org/cgit/cgit.cgi/linux-yocto-4.8/commit/?h=standard/base&id=7e0dd2f2b0971f0e3191e1ddc088e09eb9855567 fs/aufs/debug.h:95:19: warning: comparison of constant '0' with boolean expression is always false [-Wbool-compare] if (unlikely((e) < 0)) \ ^ fs/aufs/vdir.c:852:2: note: in expansion of macro 'AuTraceErr' AuTraceErr(!valid); ^~~~~~~~~~ In expansion of AuTraceErr(!valid), comparison of (!valid) and constant '0' always passes unlikely(x) false. function 'static int seek_vdir(struct file *file, struct dir_context *ctx)' is to find whether there is a valid vd_deblk following ctx->pos. return 1 means valid, 0 for not. Change to AuTraceErr(valid - 1) makes more sense. Signed-off-by: Kexin(Casey) Chen <Casey.Chen@windriver.com> Signed-off-by: Dengke Du <dengke.du@windriver.com> (From OE-Core rev: 1ba624ec410b13da9645efe7bc72908195c08259) (From OE-Core rev: 20a7e72a1fa97f673de12856b3bf53c48a05a834) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.12.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.12.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.12.bb b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
index 57ef700d05..ca664fec5d 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "standard/base"
11KBRANCH_qemux86-64 ?= "standard/base" 11KBRANCH_qemux86-64 ?= "standard/base"
12KBRANCH_qemumips64 ?= "standard/mti-malta64" 12KBRANCH_qemumips64 ?= "standard/mti-malta64"
13 13
14SRCREV_machine_qemuarm ?= "7122a8d189df29393419b3352ea11482efaa417a" 14SRCREV_machine_qemuarm ?= "6155fbae7a6b42a7608b9f251fa46cef28c0fe67"
15SRCREV_machine_qemuarm64 ?= "22f73c1fe99198a7b37aa5c76978fe19d301fd88" 15SRCREV_machine_qemuarm64 ?= "392959d6dad698bfb62de561164c2d19e17841dd"
16SRCREV_machine_qemumips ?= "1cff37b7a2bbee4bb99118e57d228ac301fb880b" 16SRCREV_machine_qemumips ?= "d46a4aebe29dcced0fea9718c249c536ab06977f"
17SRCREV_machine_qemuppc ?= "22f73c1fe99198a7b37aa5c76978fe19d301fd88" 17SRCREV_machine_qemuppc ?= "392959d6dad698bfb62de561164c2d19e17841dd"
18SRCREV_machine_qemux86 ?= "22f73c1fe99198a7b37aa5c76978fe19d301fd88" 18SRCREV_machine_qemux86 ?= "392959d6dad698bfb62de561164c2d19e17841dd"
19SRCREV_machine_qemux86-64 ?= "22f73c1fe99198a7b37aa5c76978fe19d301fd88" 19SRCREV_machine_qemux86-64 ?= "392959d6dad698bfb62de561164c2d19e17841dd"
20SRCREV_machine_qemumips64 ?= "3879cb9ed592f8d5db6b35c51761818ad60494da" 20SRCREV_machine_qemumips64 ?= "10216660f9d902f76f36514ea4ef04530e87702d"
21SRCREV_machine ?= "22f73c1fe99198a7b37aa5c76978fe19d301fd88" 21SRCREV_machine ?= "392959d6dad698bfb62de561164c2d19e17841dd"
22SRCREV_meta ?= "19d815d5a34bfaad95d87cc097cef18b594daac8" 22SRCREV_meta ?= "ca1bda8dfd3325db04dda19a531edeb66ac0d84b"
23 23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \ 24SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}" 25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"