summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-08-22 12:00:14 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 12:06:51 +0100
commit1a8c7cd0611607c6aac90f574b777dd51ae43f44 (patch)
tree8425f67d9105ed757ecad34799dbb6c5fe81949a /meta/recipes-kernel/linux/linux-yocto_4.12.bb
parent63842f885e48f3713f8aad0d7f738cc0cb9558ed (diff)
downloadpoky-1a8c7cd0611607c6aac90f574b777dd51ae43f44.tar.gz
linux-yocto: introduce 4.12 recipes
The 4.12 kernel will be the default/reference for the fall 2017 release. These recipes represent the introduction of 4.12.7 + related kernel meta data. Existing functionality has been validated against this new kernel version, and older versions will be removed in separate commits. (From OE-Core rev: 4e5044bcea68f3bac3596507f0828d3cbe869df1) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.12.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.12.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.12.bb b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
new file mode 100644
index 0000000000..ce223ca081
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
@@ -0,0 +1,44 @@
1KBRANCH ?= "standard/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# board specific branches
6KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
7KBRANCH_qemuarm64 ?= "standard/qemuarm64"
8KBRANCH_qemumips ?= "standard/mti-malta32"
9KBRANCH_qemuppc ?= "standard/qemuppc"
10KBRANCH_qemux86 ?= "standard/base"
11KBRANCH_qemux86-64 ?= "standard/base"
12KBRANCH_qemumips64 ?= "standard/mti-malta64"
13
14SRCREV_machine_qemuarm ?= "dc7fc6edebaa6d20967c953a2cd27bac5e955463"
15SRCREV_machine_qemuarm64 ?= "d09f2ce584d60ecb7890550c22a80c48b83c2e19"
16SRCREV_machine_qemumips ?= "ff11a70047bbab2c801f9b4f7b9d4bc1d38dbed1"
17SRCREV_machine_qemuppc ?= "d09f2ce584d60ecb7890550c22a80c48b83c2e19"
18SRCREV_machine_qemux86 ?= "d09f2ce584d60ecb7890550c22a80c48b83c2e19"
19SRCREV_machine_qemux86-64 ?= "d09f2ce584d60ecb7890550c22a80c48b83c2e19"
20SRCREV_machine_qemumips64 ?= "a4d6ef2c5428e57f7f9982d230b09459683ddb1d"
21SRCREV_machine ?= "d09f2ce584d60ecb7890550c22a80c48b83c2e19"
22SRCREV_meta ?= "edb42d48052dee4dbc3ed9d5e1e39c1375e85fe0"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
26
27LINUX_VERSION ?= "4.12.7"
28
29PV = "${LINUX_VERSION}+git${SRCPV}"
30
31KMETA = "kernel-meta"
32KCONF_BSP_AUDIT_LEVEL = "2"
33
34KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
35
36COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
37
38# Functionality flags
39KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
40KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
41KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
42KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
43KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
44KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"