summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-06-25 16:17:10 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-28 09:14:05 +0100
commitc48b822b9e75d053755ecd8431b5ad512faeb995 (patch)
tree89166b7883a965f23e4f14da94f5431f83715da2 /meta/recipes-kernel/linux/linux-yocto_3.4.bb
parentd85a997f2c0909788712b9985f5fb93dce880270 (diff)
downloadpoky-c48b822b9e75d053755ecd8431b5ad512faeb995.tar.gz
linux-yocto/3.4: allow kernel feature _appends to be overriden
Updating the linux-yocto 3.4 recipe's feature flags to match the 3.8 recipe, which has the following change: It was pointed out that the current way the KERNEL_FEATURES variable is appended in the base linux-yocto recipe doesn't allow the appended features to be prevented in a layer without using python code and a recipe finalize hook. To allow easier overriding of 'extra' or 'optional' features that are defined in the linux-yocto recipe, we create a KERNEL_EXTRA_FEATURES variable. This variable can be set in a layer to define extra features or cleared to prevent the recipe's extra features from being appended to the core functionality. (From OE-Core rev: 3bd592e832c6ce10947882f37564c12f4fa7f8e2) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index 9d6d8c7976..ade96be5e4 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -23,7 +23,8 @@ KMETA = "meta"
23COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64" 23COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
24 24
25# Functionality flags 25# Functionality flags
26KERNEL_FEATURES_append = " features/netfilter/netfilter.scc" 26KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
27KERNEL_FEATURES_append_qemux86=" cfg/sound.scc" 27KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
28KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
28KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc" 29KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
29KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" 30KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"