summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-28 10:08:18 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-01 14:35:41 +0100
commit61c15c03b410f645a07a1095e1a5726324d69dd1 (patch)
tree13428969fab52097b3f0ccfedee475992f77fd79 /meta/recipes-kernel/linux/linux-yocto_3.4.bb
parent05371f426ed13f35675efbcbd63ac0dd929da2e0 (diff)
downloadpoky-61c15c03b410f645a07a1095e1a5726324d69dd1.tar.gz
linux-yocto/3.4: remove 3.4 name recipes
Removing the 3.4 recipes, since support has not shifted to 3.10 and 3.14 for LTSI kernel versions, with 3.16+ as the development version. (From OE-Core rev: 362aaebbeb7b241edba00dd8ea08eab07596378c) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
deleted file mode 100644
index 3538afcf98..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1require recipes-kernel/linux/linux-yocto.inc
2
3KBRANCH = "standard/base"
4
5# board specific branches
6KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
7KBRANCH_qemumips ?= "standard/mti-malta32"
8KBRANCH_qemuppc ?= "standard/qemuppc"
9KBRANCH_qemux86 ?= "standard/common-pc/base"
10KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
11KBRANCH_qemumips64 ?= "standard/mti-malta64"
12
13SRCREV_machine_qemuarm ?= "192b56b2f529af1be014ea85667c9f3fea0afd53"
14SRCREV_machine_qemumips ?= "58fb8b8fb2f9911cac84cd840d63c8a58bada6ca"
15SRCREV_machine_qemuppc ?= "4fe50989bc8bcb3564ca37c2cffd42ac176b428d"
16SRCREV_machine_qemux86 ?= "498189ccb98f833daa2092ceee72da8c878e0009"
17SRCREV_machine_qemux86-64 ?= "498189ccb98f833daa2092ceee72da8c878e0009"
18SRCREV_machine ?= "498189ccb98f833daa2092ceee72da8c878e0009"
19SRCREV_meta ?= "a8742041c8b9f447d4ad4c3f478e022f1e4bfcfd"
20
21SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
22
23LINUX_VERSION ?= "3.4.91"
24
25PR = "${INC_PR}.5"
26PV = "${LINUX_VERSION}+git${SRCPV}"
27
28KMETA = "meta"
29
30COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
31
32# Functionality flags
33KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
34KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
35KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
36KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
37KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"