summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-09-09 18:27:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 11:23:57 +0100
commit1080d52f578ca03a48569c638ea72f53bdaf4cc7 (patch)
tree21b91bdf49f3e41cdc12348fd81f1562d6f4c813 /meta/recipes-kernel/linux/linux-yocto_3.0.bb
parent8c310ee0a94a7e15d815a2719272ffc704e857b0 (diff)
downloadpoky-1080d52f578ca03a48569c638ea72f53bdaf4cc7.tar.gz
linux-yocto: move common tasks to a common location
During the initial development of the linux-yocto recipes there were several additional tasks that needed to be run in any inheriting recipe. At that time, they didn't seem to fire if they were in the include file versus the recipes themselves. As it turns out, these tasks do work fine if placed in the linux-yocto.inc file, and the rest of the recipes can be simplified as a result. (From OE-Core rev: a1ab7c5e03df97e630dfee470ff7959d3143bf41) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index f504b74dbd..b2965582bc 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -20,9 +20,8 @@ SRCREV_machine_qemux86-64 ?= "2b2d0954a6fd12b4bb7f02f019bc62633c8060a1"
20SRCREV_machine ?= "6b2c7d65b844e686eae7d5cccb9b638887afe28e" 20SRCREV_machine ?= "6b2c7d65b844e686eae7d5cccb9b638887afe28e"
21SRCREV_meta ?= "3c9ebeed2598b74798a0c9247ef7c385e0cd96a7" 21SRCREV_meta ?= "3c9ebeed2598b74798a0c9247ef7c385e0cd96a7"
22 22
23PR = "r1" 23PR = "r2"
24PV = "${LINUX_VERSION}+git${SRCPV}" 24PV = "${LINUX_VERSION}+git${SRCPV}"
25SRCREV_FORMAT = "meta_machine"
26 25
27SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" 26SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
28 27
@@ -34,9 +33,4 @@ KERNEL_FEATURES_append=" features/taskstats"
34KERNEL_FEATURES_append_qemux86=" cfg/sound" 33KERNEL_FEATURES_append_qemux86=" cfg/sound"
35KERNEL_FEATURES_append_qemux86-64=" cfg/sound" 34KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
36 35
37# extra tasks
38addtask kernel_link_vmlinux after do_compile before do_install
39addtask validate_branches before do_patch after do_kernel_checkout
40addtask kernel_configcheck after do_configure before do_compile
41
42require linux-tools.inc 36require linux-tools.inc