summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-06-08 15:33:02 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-14 15:22:56 +0100
commitdcfb6e4d2ab5df32f0f2408a1aafd6923018555f (patch)
treefd51af5ce705ddbbce3adb6e8a088c0754c1b7ec /meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
parent9031e7e16f54e818b5e7c2d46ef720fd0f8c2cfa (diff)
downloadpoky-dcfb6e4d2ab5df32f0f2408a1aafd6923018555f.tar.gz
linux-yocto: rename recipes to explicitly indicate version
The existing recipe names for the linux-yocto kernel builds worked well when there was a single, or two versions of the kernel available. But with the impending kernel updates and retirement of older kernels, the re-use of the same recipes for different kernel versions violates the principle of least surprise. To address this, the recipes are being renamed as follows: linux-yocto_git.bb -> linux-yocto_2.6.37.bb linux-yocto-stable_git.bb -> linux-yocto_2.6.34.bb There continue to be versionless recipe names that feed into versioned recipes at the appropriate points. They are: linux-yocto-dev.bb (tracking the latest yocto dev kernel) linux-yocto-korg_head.bb (tracking korg kernels) There are no existing users of linux-yocto-stable in the master branches to convert to the new naming, so these changes work in isolation. (From OE-Core rev: 576c87349a72a94357014ff29f55db692903ed80) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_2.6.34.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.34.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
new file mode 100644
index 0000000000..66991aeded
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.34.bb
@@ -0,0 +1,49 @@
1inherit kernel
2require linux-yocto.inc
3
4KMACHINE = "common_pc"
5KMACHINE_qemux86 = "common_pc"
6KMACHINE_qemux86-64 = "common_pc_64"
7KMACHINE_qemuppc = "qemu_ppc32"
8KMACHINE_qemumips = "mti_malta32_be"
9KMACHINE_qemuarm = "arm_versatile_926ejs"
10
11LINUX_VERSION ?= "2.6.34"
12LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
13
14KMETA = wrs_meta
15KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE_EXTENSION}
16
17SRCREV_machine_qemuarm = "a2fb081b44d6368eff8d28e2fdb991c61b1f428e"
18SRCREV_machine_qemumips = "c32d40f960e3c89d07f079bec4c96dcbfc749f0b"
19SRCREV_machine_qemuppc = "96d6bc31d3caaf62a966255479cc5cee0e76b1e9"
20SRCREV_machine_qemux86 = "72ca49ab08b8eb475cec82a10049503602325791"
21SRCREV_machine_qemux86-64 = "72ca49ab08b8eb475cec82a10049503602325791"
22SRCREV_machine = "72ca49ab08b8eb475cec82a10049503602325791"
23SRCREV_meta = "ec26387cb168e9e0976999b528b5a9dd62e3157a"
24
25PR = "r1"
26PV = "${LINUX_VERSION}+git${SRCPV}"
27SRCREV_FORMAT = "meta_machine"
28
29COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
30
31# this performs a fixup on historical kernel types with embedded _'s
32python __anonymous () {
33 import bb, re, string
34
35 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
36 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
37}
38
39SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
40
41# Functionality flags
42KERNEL_REVISION_CHECKING ?= "t"
43KERNEL_FEATURES=features/netfilter
44
45# extra tasks
46addtask kernel_link_vmlinux after do_compile before do_install
47addtask validate_branches before do_patch after do_kernel_checkout
48
49require linux-tools.inc