summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei.gherzan@huawei.com>2022-08-30 16:19:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-03 13:09:49 +0100
commit2823418c13d5f353a7ee7c5907c8f656c86f0aab (patch)
treec568572b343448b28da40b510e501346433e435e /meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
parent520fca8908fd73bbc1123f7080f2cb6486870d35 (diff)
downloadpoky-2823418c13d5f353a7ee7c5907c8f656c86f0aab.tar.gz
linux-yocto: Fix COMPATIBLE_MACHINE regex match
With the current regex expression, a machine that is not part of the compatible could match the regex expression. For example, consider the following COMPATIBLE_MACHINE: COMPATIBLE_MACHINE = "qemuarm|qemuarm64" A machine definition bringing in "qemuarm-foo" would match against the COMPATIBLE_MACHINE pattern above (see base.bbclass for implementation details). Fix this by matching the start and the end of the string. (From OE-Core rev: 26a6fdef2a6c91c7ad3dde932596a17ffed6ca7b) Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
index d7aa3281cc..d9b5e00378 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
@@ -24,7 +24,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \ 24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}" 25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
26 26
27COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5" 27COMPATIBLE_MACHINE = "^(qemux86|qemux86-64|qemuarm|qemuarmv5)$"
28 28
29# Functionality flags 29# Functionality flags
30KERNEL_FEATURES = "" 30KERNEL_FEATURES = ""