summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-01-11 11:58:26 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-18 11:47:03 +0000
commite9280d13a88701500ffdcb9ba51abeb5c322ca0d (patch)
tree34fdaae0fe88ea86ee602f7d9c80c7ccff255ed6 /meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
parent8c3276ecea38d4d67c22e6db49060b2d4b457278 (diff)
downloadpoky-e9280d13a88701500ffdcb9ba51abeb5c322ca0d.tar.gz
linux-yocto: introduce v4.4 standard/preempt-rt/standard kernel
The 4.4 kernel has been under test via linux-yocto-dev, and is the next LTS/LTSI kernel. So we take our -dev support and created a named/versioned recipe for use in upcoming releases. (From OE-Core rev: 2dbc788bc3988532f0932e8e51e24ba702c28f6a) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
new file mode 100644
index 0000000000..d348c0a628
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.4.bb
@@ -0,0 +1,23 @@
1KBRANCH ?= "standard/tiny/base"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "4.4"
8
9KMETA = "kernel-meta"
10KCONF_BSP_AUDIT_LEVEL = "2"
11
12SRCREV_machine ?= "2dadc3524fcbce0c46f5db65b7c20c673fc60503"
13SRCREV_meta ?= "ad9d3f01300ba350563e17db00b2518302e172f6"
14
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
19
20COMPATIBLE_MACHINE = "(qemux86)"
21
22# Functionality flags
23KERNEL_FEATURES = ""