summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-12-16 22:38:23 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-18 16:19:34 +0000
commit5cc1a7ceccfc61a5a574934da6c39dfc4e3a108b (patch)
treea491d41d85e6dba6b413b8be514cef24623dc4d3 /meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
parentb701df379e62c0ef25d884191c782088df811fa5 (diff)
downloadpoky-5cc1a7ceccfc61a5a574934da6c39dfc4e3a108b.tar.gz
linux-yocto: introduce 4.19 recipes
Introduce the 4.19 linux kernel as the reference for LTS and eventually LSB distros. For now, we keep the other versions around until the h/w reference BSPs are updated and 4.20+ are available as the "latest" kernel. This avoid updating qemu* to 4.19 as the default for a small transition window. (From OE-Core rev: d52d68adff8fc2b9b2a98405f57fb06d2ed26c24) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
new file mode 100644
index 0000000000..c25202fb5f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.19.bb
@@ -0,0 +1,32 @@
1KBRANCH ?= "v4.19/standard/tiny/base"
2KBRANCH_qemuarm ?= "v4.15/standard/tiny/arm-versatile-926ejs"
3
4LINUX_KERNEL_TYPE = "tiny"
5KCONFIG_MODE = "--allnoconfig"
6
7require recipes-kernel/linux/linux-yocto.inc
8
9LINUX_VERSION ?= "4.19.5"
10LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
11
12DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
13DEPENDS += "openssl-native util-linux-native"
14
15KMETA = "kernel-meta"
16KCONF_BSP_AUDIT_LEVEL = "2"
17
18SRCREV_machine_qemuarm ?= "afd1ddee4ec8cc65d585e2c75bbcf31d9650c827"
19SRCREV_machine ?= "ba6690e7b65aaa1d1030e51498aaf2c5eb7e88b1"
20SRCREV_meta ?= "f7bff5bff6ef6ceadfb4661a6ef3ed1f95bd6b2b"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"
26
27COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm"
28
29# Functionality flags
30KERNEL_FEATURES = ""
31
32KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"