summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-08-24 10:59:57 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-28 10:30:28 +0100
commit74b2b627ba5ae5787a708dd796009713c5e9323a (patch)
tree4f4d84d2869804450c93c6777feaccf4f5458833 /meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
parent43344a13af837c27ff61a6aa5124af53861b6358 (diff)
downloadpoky-74b2b627ba5ae5787a708dd796009713c5e9323a.tar.gz
linux-yocto: introduce 4.18 recipes
Introducing the 4.18 kernel as the 'newest' kernel for the oe core release. This update includes tweaked configs, carried forward BSPs, features (aufs, yaffs2, preempt-rt) and has been tested on all arches for boot and performance sanity. (From OE-Core rev: e08069b6855ba8cc3ef3c6e704f08f9259d77330) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
new file mode 100644
index 0000000000..1f0b35ec25
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.18.bb
@@ -0,0 +1,29 @@
1KBRANCH ?= "v4.18/standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "4.18.3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
9
10DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
11DEPENDS += "openssl-native util-linux-native"
12
13KMETA = "kernel-meta"
14KCONF_BSP_AUDIT_LEVEL = "2"
15
16SRCREV_machine ?= "eba03655e8e436ef6090100423bcea43e4911478"
17SRCREV_meta ?= "1f78e20cc98dd46637c0beb6007214fb3650992c"
18
19PV = "${LINUX_VERSION}+git${SRCPV}"
20
21SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
22 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.18;destsuffix=${KMETA}"
23
24COMPATIBLE_MACHINE = "qemux86|qemux86-64"
25
26# Functionality flags
27KERNEL_FEATURES = ""
28
29KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"