summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-08-22 12:00:14 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 12:06:51 +0100
commit1a8c7cd0611607c6aac90f574b777dd51ae43f44 (patch)
tree8425f67d9105ed757ecad34799dbb6c5fe81949a /meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
parent63842f885e48f3713f8aad0d7f738cc0cb9558ed (diff)
downloadpoky-1a8c7cd0611607c6aac90f574b777dd51ae43f44.tar.gz
linux-yocto: introduce 4.12 recipes
The 4.12 kernel will be the default/reference for the fall 2017 release. These recipes represent the introduction of 4.12.7 + related kernel meta data. Existing functionality has been validated against this new kernel version, and older versions will be removed in separate commits. (From OE-Core rev: 4e5044bcea68f3bac3596507f0828d3cbe869df1) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
new file mode 100644
index 0000000000..ff395e0ad7
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
@@ -0,0 +1,25 @@
1KBRANCH ?= "standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "4.12.7"
8
9KMETA = "kernel-meta"
10KCONF_BSP_AUDIT_LEVEL = "2"
11
12SRCREV_machine ?= "d09f2ce584d60ecb7890550c22a80c48b83c2e19"
13SRCREV_meta ?= "edb42d48052dee4dbc3ed9d5e1e39c1375e85fe0"
14
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
19
20COMPATIBLE_MACHINE = "(qemux86$)"
21
22# Functionality flags
23KERNEL_FEATURES = ""
24
25KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"