summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-07-21 11:21:07 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-25 14:41:44 +0100
commit3a4b0d63738d6e368d03ba0243d5b05484434b1f (patch)
treeb875784bfdb827cf784d7316e624b00b70b9c386 /meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
parentf7ee1c9839af657f42e10bbd2a5d4d647fcf2d94 (diff)
downloadpoky-3a4b0d63738d6e368d03ba0243d5b05484434b1f.tar.gz
linux-yocto: introduce 4.1 versioned recipes
Updating the linux-yocto kernel recipes to include a named/versioned 4.1 recipe. This will be the LTSI kernel, and the 3.14 and 3.19 kernels will be removed in subsequent commites (once reference boards have transitioned). (From OE-Core rev: c027c1283e6444ab05f444eb5d292ec1a36b5821) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
new file mode 100644
index 0000000000..38167cc2e8
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -0,0 +1,23 @@
1KBRANCH ?= "standard/tiny/base"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "4.1.2"
8
9KMETA = "kernel-meta"
10KCONF_BSP_AUDIT_LEVEL = "2"
11
12SRCREV_machine ?= "4e30e64c44df9e59bd13239951bb8d2b5b276e6f"
13SRCREV_meta ?= "45393dd54f5ad77d43014c407c2b3520da42f427"
14
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
19
20COMPATIBLE_MACHINE = "(qemux86)"
21
22# Functionality flags
23KERNEL_FEATURES = ""