summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-08-30 12:06:31 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-01 22:33:07 +0100
commit636188943de3355e6e975be8cd8c0b368ce2c5ec (patch)
tree63561c90021c5e8aed0251dbcc1ccc58c195bd6e /meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
parent8352682c3b91edf2136e35f79777c80d5c7dea31 (diff)
downloadpoky-636188943de3355e6e975be8cd8c0b368ce2c5ec.tar.gz
linux-yocto: introduce 5.2 recipes
Introducing the 5.2 linux-yocto reference kernels. 5.0 is EOL and will be removed, leaving 4.19 (LTS) and 5.2 as the reference kernels. This has been build/boot tested on all qemu architectures for core-image-kernel-dev, and graphics tesed via core-image-sato. No blocking issues have been found. (From OE-Core rev: 14472621e4a0d3d3cf4c0bc43a8b7344c10008e3) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
new file mode 100644
index 0000000000..1126734dbb
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.2.bb
@@ -0,0 +1,44 @@
1KBRANCH ?= "v5.2/standard/preempt-rt/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of
8# core-image-rt-sdk, core-image-rt.
9python () {
10 if d.getVar("KERNEL_PACKAGE_NAME") == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
11 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12}
13
14SRCREV_machine ?= "abe36b584560b3ab9c4c2ece15d5e44494f02427"
15SRCREV_meta ?= "552f94eb15525c2be2e56615880f1018c3bfbb8a"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.2;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "5.2.10"
21
22LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
23
24DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
25DEPENDS += "openssl-native util-linux-native"
26
27PV = "${LINUX_VERSION}+git${SRCPV}"
28
29KMETA = "kernel-meta"
30KCONF_BSP_AUDIT_LEVEL = "2"
31
32LINUX_KERNEL_TYPE = "preempt-rt"
33
34COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuarmv5|qemuarm64|qemuppc|qemumips)"
35
36KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"
37
38# Functionality flags
39KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
40KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
41KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
42KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
43KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
44KERNEL_FEATURES_append = "${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "" ,d)}"