summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-10-21 11:35:31 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-25 17:51:19 +0100
commit143f9a3fa8dfd16aa107f03038383f2c578d7d49 (patch)
tree5ac70756a4b8b11dfd8b526c041c6efcb505473b /meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
parent4fd9b03db4a201b0523a2aecf1cc97fc47b4b614 (diff)
downloadpoky-143f9a3fa8dfd16aa107f03038383f2c578d7d49.tar.gz
linux-yocto/4.8: update to v4.8.3
Integrating the korg -stable release One commit of note is the fix for CVE-2016-5195 (http://dirtycow.ninja/): mm: remove gup_flags FOLL_WRITE games from __get_user_pages() The remaining changes are covered by the following shortlog export: mm: remove gup_flags FOLL_WRITE games from __get_user_pages() Make __xfs_xattr_put_listen preperly report errors. scsi: configure runtime pm before calling device_add in scsi_add_host_with_dma v4l: rcar-fcp: Don't force users to check for disabled FCP support Linux 4.8.2 tpm_crb: fix crb_req_canceled behavior tpm: fix a race condition in tpm2_unseal_trusted() ima: use file_dentry() Bluetooth: Add a new 04ca:3011 QCA_ROME device ARM: cpuidle: Fix error return code ARM: dts: MSM8660 remove flags from SPMI/MPP IRQs ARM: dts: MSM8064 remove flags from SPMI/MPP IRQs ARM: dts: mvebu: armada-390: add missing compatibility string and bracket ARM: fix delays x86/dumpstack: Fix x86_32 kernel_stack_pointer() previous stack access x86/mm/pkeys: Do not skip PKRU register if debug registers are not used arch/x86: Handle non enumerated CPU after physical hotplug x86/apic: Get rid of apic_version[] array x86/platform/intel-mid: Keep SRAM powered on at boot x86/platform/intel-mid: Add Intel Penwell to ID table x86/cpu: Rename Merrifield2 to Moorefield x86/pkeys: Make protection keys an "eager" feature x86/irq: Prevent force migration of irqs which are not in the vector domain x86/boot: Fix kdump, cleanup aborted E820_PRAM max_pfn manipulation arm64: fix dump_backtrace/unwind_frame with NULL tsk KVM: PPC: BookE: Fix a sanity check KVM: arm/arm64: vgic: Don't flush/sync without a working vgic KVM: arm64: Require in-kernel irqchip for PMU support KVM: MIPS: Drop other CPU ASIDs on guest MMU changes KVM: PPC: Book3s PR: Allow access to unprivileged MMCR2 register xen/x86: Update topology map for PV VCPUs mfd: wm8350-i2c: Make sure the i2c regmap functions are compiled mfd: 88pm80x: Double shifting bug in suspend/resume mfd: atmel-hlcdc: Do not sleep in atomic context mfd: rtsx_usb: Avoid setting ucr->current_sg.status ALSA: usb-line6: use the same declaration as definition in header for MIDI manufacturer ID ALSA: usb-audio: Extend DragonFly dB scale quirk to cover other variants ALSA: ali5451: Fix out-of-bound position reporting phy: sun4i-usb: Use spinlock to guard phyctl register access usb: dwc3: fix Clear Stall EP command failure timekeeping: Fix __ktime_get_fast_ns() regression usb: storage: fix runtime pm issue in usb_stor_probe2 Linux 4.8.1 ALSA: hda - Add the top speaker pin config for HP Spectre x360 ALSA: hda - Fix headset mic detection problem for several Dell laptops ALSA: hda - Adding one more ALC255 pin definition for headset problem Revert "usbtmc: convert to devm_kzalloc" USB: serial: cp210x: Add ID for a Juniper console usb: usbip: vudc: fix left shift overflow Staging: fbtft: Fix bug in fbtft-core usb: misc: legousbtower: Fix NULL pointer deference Using BUG_ON() as an assert() is _never_ acceptable arm64: debug: avoid resetting stepping state machine when TIF_SINGLESTEP Using BUG_ON() as an assert() is _never_ acceptable (From OE-Core rev: deb7d22d00ace3bfa1252e0a5df1961386231bc2) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
index fc1c40caf7..00c3d2c7bc 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.8.bb
@@ -11,13 +11,13 @@ python () {
11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it") 11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12} 12}
13 13
14SRCREV_machine ?= "b266f7ba78f0cb3d7073e1bf7bd7dfc92bec7431" 14SRCREV_machine ?= "320bceb35315d118c1e209effd441eb8a8dbad57"
15SRCREV_meta ?= "552a83790b1797b6dd4e4c48ff5bc8f215ed57da" 15SRCREV_meta ?= "6d028d2818603cd82cfb707b3231b8a9038f13bb"
16 16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.8.git;branch=${KBRANCH};name=machine \ 17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.8.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.8;destsuffix=${KMETA}" 18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.8;destsuffix=${KMETA}"
19 19
20LINUX_VERSION ?= "4.8" 20LINUX_VERSION ?= "4.8.3"
21 21
22PV = "${LINUX_VERSION}+git${SRCPV}" 22PV = "${LINUX_VERSION}+git${SRCPV}"
23 23