summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-12-16 22:38:23 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-18 16:19:34 +0000
commit5cc1a7ceccfc61a5a574934da6c39dfc4e3a108b (patch)
treea491d41d85e6dba6b413b8be514cef24623dc4d3 /meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
parentb701df379e62c0ef25d884191c782088df811fa5 (diff)
downloadpoky-5cc1a7ceccfc61a5a574934da6c39dfc4e3a108b.tar.gz
linux-yocto: introduce 4.19 recipes
Introduce the 4.19 linux kernel as the reference for LTS and eventually LSB distros. For now, we keep the other versions around until the h/w reference BSPs are updated and 4.20+ are available as the "latest" kernel. This avoid updating qemu* to 4.19 as the default for a small transition window. (From OE-Core rev: d52d68adff8fc2b9b2a98405f57fb06d2ed26c24) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
new file mode 100644
index 0000000000..06caf06d1c
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.19.bb
@@ -0,0 +1,43 @@
1KBRANCH ?= "v4.19/standard/preempt-rt/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of
8# core-image-rt-sdk, core-image-rt.
9python () {
10 if d.getVar("KERNEL_PACKAGE_NAME") == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
11 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12}
13
14SRCREV_machine ?= "36ac11d2cb46f951843586935292c628d304e113"
15SRCREV_meta ?= "f7bff5bff6ef6ceadfb4661a6ef3ed1f95bd6b2b"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.19;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.19.5"
21
22LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
23
24DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
25DEPENDS += "openssl-native util-linux-native"
26
27PV = "${LINUX_VERSION}+git${SRCPV}"
28
29KMETA = "kernel-meta"
30KCONF_BSP_AUDIT_LEVEL = "2"
31
32LINUX_KERNEL_TYPE = "preempt-rt"
33
34COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuarm64|qemuppc|qemumips)"
35
36KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
37
38# Functionality flags
39KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
40KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
41KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
42KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
43KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"