summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-02-06 11:21:52 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-15 11:23:10 +0000
commitd99333b0659d13c1ade4abb4c80e547023745528 (patch)
tree0eff9aaa1280ac9524be190a15a2a2fca5d33eb4 /meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
parente23d41fed9aa2f61a2431b9852053437918f7bcc (diff)
downloadpoky-d99333b0659d13c1ade4abb4c80e547023745528.tar.gz
linux-yocto: introduce 4.14 recipes
This commit makes the 4.14 kernel available for use with the Yocto configuration fragments and qemu* BSPs. It has been tested for x86,arm,mips and powerpc against the lsb, core* and glibc/mulsc test matrix. This will serve as the LTS kernel in master, with others being removed in subsequent commits. (From OE-Core rev: 04254d4cc9e6399afd027727864e237cb8006d6d) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
new file mode 100644
index 0000000000..669a2606ae
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
@@ -0,0 +1,38 @@
1KBRANCH ?= "v4.14/standard/preempt-rt/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of
8# core-image-rt-sdk, core-image-rt.
9python () {
10 if d.getVar("KERNEL_PACKAGE_NAME") == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
11 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12}
13
14SRCREV_machine ?= "ae0fb21fdde3df106d7dad76620bdf39721425e2"
15SRCREV_meta ?= "0e964663a7978bdb459c28f3777e1b6dfe97d93d"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.14.16"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24KMETA = "kernel-meta"
25KCONF_BSP_AUDIT_LEVEL = "2"
26
27LINUX_KERNEL_TYPE = "preempt-rt"
28
29COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuppc|qemumips)"
30
31KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"
32
33# Functionality flags
34KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
35KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
36KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
37KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
38KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"