summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-05-27 12:18:35 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-29 19:36:01 +0100
commitec2d08375be9a9fdd6bb170aa4c342640cda3505 (patch)
tree45f8389eb2cde4405b844265a2d4ff1f6e42c227 /meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
parent217448b91185dd8719d03e2f4d55ba44105a42d0 (diff)
downloadpoky-ec2d08375be9a9fdd6bb170aa4c342640cda3505.tar.gz
linux-yocto/4.1: fix musb compilation error
We had a partial musb change merged into the 4.1 tree, which resulted in: | kernel-source/drivers/usb/musb/musb_dsps.c: In function 'dsps_create_musb_pdev': | kernel-source/drivers/usb/musb/musb_dsps.c:750:8: error: 'struct musb_hdrc_config' has no member named 'maximum_speed' | config->maximum_speed = usb_get_maximum_speed(&parent->dev); | ^~ By backporting commit: 9b7537642cb6a [usb: musb: set the controller speed based on the config setting] We get our missing structure field, and we can once again build musb. [YOCTO: #9680] (From OE-Core rev: b746223787a0195c3a4d16523003c62ec0ac8451) (From OE-Core rev: b6b0a40e5c9ffe1a2150b36cb2a447a1361d474b) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster@mvista.com> fixup as meta hash was not updated to latest Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
index 51fa3adeb2..ce54fc58bb 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
@@ -11,7 +11,7 @@ python () {
11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it") 11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12} 12}
13 13
14SRCREV_machine ?= "320892013ad33ab41f530ad321939aec07d09d22" 14SRCREV_machine ?= "e22280e8c2905d96c7cc5917df202b6ed904d042"
15SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75" 15SRCREV_meta ?= "d6e1f4bfc254c677a8dfef92f0ad8c78bdeeea75"
16 16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \ 17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \