summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-06-12 12:41:09 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-15 15:12:43 +0100
commitde4bd3767c18a9ab29282e74a3353c684dbd763c (patch)
treedcb45d9abffac0f4e558612a5b35ee569386a14f /meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
parentd51d204e9cd9f3960d63ee568611b6d8c639cbd4 (diff)
downloadpoky-de4bd3767c18a9ab29282e74a3353c684dbd763c.tar.gz
linux-yocto/3.4: create linux-yocto-rt recipe
Adding the 3.4 variant of the linux-yocto-rt recipe. This updates to 3.4.1-rt9, and builds and boots on the supported targets. (From OE-Core rev: 7f007994cbc5f188439ad2b26f60dbcc1c2763bd) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
new file mode 100644
index 0000000000..81730ea085
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
@@ -0,0 +1,32 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4KBRANCH = "standard/preempt-rt/base"
5KBRANCH_qemuppc = "standard/preempt-rt/qemu-ppc32"
6
7LINUX_VERSION ?= "3.4.1"
8LINUX_KERNEL_TYPE = "preempt-rt"
9
10KMETA = "meta"
11
12SRCREV_machine ?= "9dc5e97d144abb03deec411acb9c64883602cff9"
13SRCREV_machine_qemuppc ?= "241a41d6104df6916280f1273894bbd7fa7cdd71"
14SRCREV_meta ?= "aa226dcc5a1351fae49da40d77b718c4c3a76e7c"
15
16PR = "r0"
17PV = "${LINUX_VERSION}+git${SRCPV}"
18
19SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
20
21# Omit broken machines from COMPATIBLE_MACHINE
22# qemuppc hangs at boot
23# qemumips panics at boot
24COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
25
26# Functionality flags
27KERNEL_FEATURES = "features/netfilter"
28KERNEL_FEATURES_append = " features/taskstats"
29KERNEL_FEATURES_append_qemux86 = " cfg/sound"
30KERNEL_FEATURES_append_qemux86-64 = " cfg/sound"
31
32require recipes-kernel/linux/linux-tools.inc