summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-08-09 15:48:27 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-19 10:45:55 +0100
commit9ede55adf7e0f717fcf485b3bb6c3749496d7a81 (patch)
tree2553579d15c3fb36bb15d2daa567b3674edb6fe4 /meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
parent101bdc6ca2ebb019ab9173a708359e086e7ebe78 (diff)
downloadpoky-9ede55adf7e0f717fcf485b3bb6c3749496d7a81.tar.gz
linux-yocto/3.4: BSP, uprobes, config and cleanups
Updating the linux-yocto 3.4 recipe with consolidated fixes, BSPs and cleanups. From the kernel meta branch: 28bcd46 meta: move emgd features to staging 6c01949 meta: Crystal Forest Machine Created. 3c19c4d meta/qemuppc: remove redundant profiling options a5da4d5 meta: kgdb: update configuration for out of box functionality 1d13e00 meta: update status/series and patches for v3.4 b96c408 fsl-mpc8315e-rdb: replace leading dot with hash in cfg file 7c9a3b0 usb: fix scc and cfg filename collision with ktypes/base/ aa0e1f6 kconfig: make CONFIG_BLOCK=y part of base config 3d1a2f2 kconfig: add tty/serial file to hardware listing 60b600f routerstationpro: specify chosen filesystems in audit input. 8b5c8c7 routerstationpro: add config data for audit purposes d7ae8fa meta: add ath79 Kconfig to hardware listing. And from the standard branch: c77666c powerpc: uprobes: removed external declaration of uprobe_get_swbp_addr. c262f3e powerpc: Uprobes port to powerpc d40e73d powerpc: Add trap_nr to thread_struct 6a64190 Revert "This is the port of uprobes to powerpc. Usage is similar to x86." e422119 Revert "powerpc: uprobes: removed external declaration of uprobe_get_swbp_addr." d4ef82f keys: kill task_struct->replacement_session_keyring 1cc141e keys: kill the dummy key_replace_session_keyring() 090ca45 keys: change keyctl_session_to_parent() to use task_work_add() 61bc7a8 genirq: reimplement exit_irq_thread() hook via task_work_add() 5ee34dd task_work_add: generic process-context callbacks 70754de move key_repace_session_keyring() into tracehook_notify_resume() 6f70bc1 powerpc: uprobes: removed external declaration of uprobe_get_swbp_addr. e5f6a4c This is the port of uprobes to powerpc. Usage is similar to x86. 2bc4597 On RISC architectures like powerpc, instructions are fixed size. Instruction analysis on such pl 8893371 perf probe: Detect probe target when m/x options are absent 544d531a perf probe: Provide perf interface for uprobes 103b503 tracing: Fix kconfig warning due to a typo 9bb012e tracing: Provide trace events interface for uprobes b9b7281 tracing: Extract out common code for kprobes/uprobes trace events 91f0360 tracing: Modify is_delete, is_return from int to bool a8600f2 uprobes/core: Decrement uprobe count before the pages are unmapped a252056 uprobes/core: Make background page replacement logic account for rss_stat counters 3efc15b uprobes/core: Optimize probe hits with the help of a counter 20f3d76 uprobes/core: Allocate XOL slots for uprobes use 77bfad8 uprobes/core: Handle breakpoint and singlestep exceptions 7196d9a uprobes/core: Rename bkpt to swbp c99bc18 uprobes/core: Make order of function parameters consistent across functions 7e9be99 uprobes/core: Make macro names consistent c4247f2 uprobes: Update copyright notices f066ff9 uprobes/core: Move insn to arch specific structure e91cf65 uprobes/core: Remove uprobe_opcode_sz 942b91c uprobes/core: Make instruction tables volatile 56c1e99 uprobes: Move to kernel/events/ 0a7ad1c uprobes/core: Clean up, refactor and improve the code 3760d62 uprobes, mm, x86: Add the ability to install and remove uprobes breakpoints Two BSP updates: - Crystal Forest Machine has been added - routerstationpro configuration updates for 3.4 (From OE-Core rev: bd05dcb634cbb4022b4189985585f73c86f01fae) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
index b995a42d9b..1c4d2fddaa 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.4.bb
@@ -8,9 +8,9 @@ LINUX_KERNEL_TYPE = "preempt-rt"
8 8
9KMETA = "meta" 9KMETA = "meta"
10 10
11SRCREV_machine ?= "50cc910aeb0571921b7ad86091ec2dc621adf67f" 11SRCREV_machine ?= "7c172e3f3d3109b23a1107f512f9463d3108f5b2"
12SRCREV_machine_qemuppc ?= "713b13fa93d4d0b1780b31ed9bbb7a5527447886" 12SRCREV_machine_qemuppc ?= "ee88dfc005ec2cdbfe5fda3c27e5f8a175991948"
13SRCREV_meta ?= "8d2012649516f3c489295a31fb9ea7afd1b464e4" 13SRCREV_meta ?= "28bcd46af1d592dab39bd8a0891c872454fde8bc"
14 14
15PR = "${INC_PR}.0" 15PR = "${INC_PR}.0"
16PV = "${LINUX_VERSION}+git${SRCPV}" 16PV = "${LINUX_VERSION}+git${SRCPV}"