summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-06-07 15:59:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-08 11:56:31 +0100
commit9cf85014444a55ecfd2bd794ff267f68fa216928 (patch)
tree7c8186364190f9c2fb4d10081968bf79a3747576 /meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
parentb0789103afd51fb74b8dd47e0b5584f65c96b90c (diff)
downloadpoky-9cf85014444a55ecfd2bd794ff267f68fa216928.tar.gz
linux-yocto: add machine aliases for yocto BSPs
To avoid mapping machine names to kernel machine names in recipes, we can define multiple KMACHINE names for a single in tree board. This allows the tools to match a board description to multiple different MACHINEs. As a result, we can remove the explicit KMACHINE mappings from the linux-yocto recipes and allow the KMACHINE=${MACHINE} default to handle mappings. Individual recipes an bbappends can override this as required. (From OE-Core rev: d3dc05a4b808136876cb257a568737abfaceeadd) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
index f881c1f2f6..f27e39e73e 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.2.bb
@@ -1,13 +1,6 @@
1inherit kernel 1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc 2require recipes-kernel/linux/linux-yocto.inc
3 3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common-pc"
6KMACHINE_qemux86-64 = "common-pc-64"
7KMACHINE_qemuarm = "arm-versatile-926ejs"
8KMACHINE_qemuppc = "qemu-ppc32"
9KMACHINE_qemumips = "mti-malta32-be"
10
11KBRANCH = "standard/preempt-rt/base" 4KBRANCH = "standard/preempt-rt/base"
12KBRANCH_qemuppc = "standard/preempt-rt/qemu-ppc32" 5KBRANCH_qemuppc = "standard/preempt-rt/qemu-ppc32"
13 6
@@ -18,7 +11,7 @@ KMETA = "meta"
18 11
19SRCREV_machine ?= "fe2630b38159ea7b9cf977b5fed40a9917002087" 12SRCREV_machine ?= "fe2630b38159ea7b9cf977b5fed40a9917002087"
20SRCREV_machine_qemuppc ?= "0259e5a3ef568c6979f2cb31280a43c55c784f4f" 13SRCREV_machine_qemuppc ?= "0259e5a3ef568c6979f2cb31280a43c55c784f4f"
21SRCREV_meta ?= "49f931bc294d5b6be60502bbd448cff5aa766235" 14SRCREV_meta ?= "0a18db9fc89a0e030e8c7b8d01fe03c5ca4197e3"
22 15
23PR = "r1" 16PR = "r1"
24PV = "${LINUX_VERSION}+git${SRCPV}" 17PV = "${LINUX_VERSION}+git${SRCPV}"