summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-09-18 18:09:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-09-18 19:49:41 +0100
commit4ed858bc765ec6f354731f6c6777b07ce51b4792 (patch)
tree6004c2cb1285b0c8d03b0f9a335ab0c978320e46 /meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
parent2ad268ff8e464929c84577a8eb8d0458f2351a2e (diff)
downloadpoky-4ed858bc765ec6f354731f6c6777b07ce51b4792.tar.gz
linux-yocto/3.10: fix long perf compile times1.5_M5.rc3
perf's builtin-sched.c triggers extremly long build times on some architectures due to gcc 4.7+ var-tracking functionality. To fix this, we can cherry pick the 3.12 commit: f36f83f94 [perf sched: Move struct perf_sched definition out of cmd_sched()] With this change build times are reduced from 15 to 20 minutes for qemuarm to: real 2m19.940s user 1m35.438s sys 0m11.165s For kernel's that are not carrying this patch, the following can be added to the perf recipe to also fix the issue: +++ b/meta/recipes-kernel/perf/perf.bb @@ -68,6 +68,7 @@ EXTRA_OEMAKE = \ CC="${CC}" \ AR="${AR}" \ perfexecdir=${libexecdir} \ + EXTRA_CFLAGS="-fno-var-tracking" \ NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${SCRIPTING_DEFINES} \ (From OE-Core rev: 82ad5305381c2f541ef051a8fc28243cd91776fe) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
index 65fb5f050d..b6ad4d4b5b 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.10.bb
@@ -3,8 +3,8 @@ require recipes-kernel/linux/linux-yocto.inc
3KBRANCH = "standard/preempt-rt/base" 3KBRANCH = "standard/preempt-rt/base"
4KBRANCH_qemuppc = "standard/preempt-rt/qemuppc" 4KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
5 5
6SRCREV_machine ?= "4de6b6b24c44ef644b46405a85c550128d4a779a" 6SRCREV_machine ?= "f1e003e9441f0366d7b9a2209ef3108438745ea3"
7SRCREV_machine_qemuppc ?= "24a1786e5ed0d479638af5738375e396bf4c922c" 7SRCREV_machine_qemuppc ?= "12be459359d5b20dbf856aa3649304c6f618d420"
8SRCREV_meta ?= "4f689aa30a2c9cf5dceb2fa3696d2cb208ee9173" 8SRCREV_meta ?= "4f689aa30a2c9cf5dceb2fa3696d2cb208ee9173"
9 9
10SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta" 10SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"