summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-11-20 00:30:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-02 15:19:57 +0000
commit70e26e6995b9b73c26365250dfa678994d336c68 (patch)
tree435135caa50effdbaf07d7a4e3d217fffe2fef75 /meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
parent44cf077ac146a568e28d7a69da4a4f48c55cd2cf (diff)
downloadpoky-70e26e6995b9b73c26365250dfa678994d336c68.tar.gz
linux-yocto: remove 2.6.34 recipes
To limit the number of active recipes in master to 3 (v2.6.37, v3.0 and -dev), the 2.6.34 recipe can now be removed. It is available in the previous release branches and will continue to work, but won't be updated as part of ongoing dev efforts. (From OE-Core rev: bd5f38b0bb063b2fb2e46abc5d7ffaed4b6b502c) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb b/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
deleted file mode 100644
index 26423255c7..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common_pc"
6KMACHINE_qemux86-64 = "common_pc_64"
7
8LINUX_VERSION ?= "2.6.34"
9LINUX_KERNEL_TYPE = "preempt_rt"
10LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
11
12KMETA = wrs_meta
13KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
14
15SRCREV_machine_qemux86 = "439602eb6acd53d9beb8493710310214fc7bd749"
16SRCREV_machine_qemux86-64 = "3c84c45ad3c3592f9c7ff4076de9bee417cd322e"
17SRCREV_machine = "439602eb6acd53d9beb8493710310214fc7bd749"
18SRCREV_meta = "e1f85a470934a0cf6abde5d95533e74501822c6b"
19
20PR = "r3"
21PV = "${LINUX_VERSION}+git${SRCPV}"
22
23COMPATIBLE_MACHINE = "(qemux86|qemux86-64)"
24
25# this performs a fixup on the SRCREV for new/undefined BSPs
26python __anonymous () {
27 import bb, re, string
28
29 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
30 d.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype)
31}
32
33SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
34
35# Functionality flags
36KERNEL_FEATURES=features/netfilter
37
38require recipes-kernel/linux/linux-tools.inc