summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-dev.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2016-09-26 14:36:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-28 10:16:03 +0100
commitc6fbb37c823ca65b8c6b680f63036a47834aaf4d (patch)
tree95d3340585d5c5da5f035dcab45698a412f89229 /meta/recipes-kernel/linux/linux-yocto-dev.bb
parent04a3b6c0ca4e127a0a010c31e432a1c2e356b30c (diff)
downloadpoky-c6fbb37c823ca65b8c6b680f63036a47834aaf4d.tar.gz
linux-yocto: Move PREFERRED_PROVIDER check to be generic
This check ensures that when the PREFERRED_PROVIDER for virtual/kernel changes, the previous instances gets removed correctly so when the new instance installs files into the shared area there is not an overlap of old and new. [YOCTO #10278] (From OE-Core rev: 6b67018c2c0229a91fbc55c6aafb86781caf2499) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-dev.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index dbe58477f5..9154bb7c31 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -14,15 +14,6 @@ require recipes-kernel/linux/linux-yocto.inc
14# provide this .inc to set specific revisions 14# provide this .inc to set specific revisions
15include recipes-kernel/linux/linux-yocto-dev-revisions.inc 15include recipes-kernel/linux/linux-yocto-dev-revisions.inc
16 16
17# Skip processing of this recipe if it is not explicitly specified as the
18# PREFERRED_PROVIDER for virtual/kernel. This avoids network access required
19# by the use of AUTOREV SRCREVs, which are the default for this recipe.
20python () {
21 if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
22 d.delVar("BB_DONT_CACHE")
23 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
24}
25
26KBRANCH = "standard/base" 17KBRANCH = "standard/base"
27KMETA = "kernel-meta" 18KMETA = "kernel-meta"
28 19