summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-omap_2.6.29.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-kernel/linux/linux-omap_2.6.29.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-omap_2.6.29.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-omap_2.6.29.bb159
1 files changed, 159 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-omap_2.6.29.bb b/meta/recipes-kernel/linux/linux-omap_2.6.29.bb
new file mode 100644
index 0000000000..f0769f8556
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-omap_2.6.29.bb
@@ -0,0 +1,159 @@
1require linux.inc
2
3DESCRIPTION = "Linux kernel for OMAP processors"
4KERNEL_IMAGETYPE = "uImage"
5
6COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom"
7
8DEFAULT_PREFERENCE = "-1"
9DEFAULT_PREFERENCE_overo = "1"
10DEFAULT_PREFERENCE_beagleboard = "1"
11
12SRCREV = "58cf2f1425abfd3a449f9fe985e48be2d2555022"
13
14# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
15PR_append = "+gitr${SRCREV}"
16
17SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
18 file://defconfig"
19
20SRC_URI_append = " \
21 file://no-empty-flash-warnings.patch;patch=1 \
22 file://no-cortex-deadlock.patch;patch=1 \
23 file://read_die_ids.patch;patch=1 \
24 file://fix-install.patch;patch=1 \
25 file://dss2/0001-Revert-gro-Fix-legacy-path-napi_complete-crash.patch;patch=1 \
26 file://dss2/0002-OMAPFB-move-omapfb.h-to-include-linux.patch;patch=1 \
27 file://dss2/0003-DSS2-OMAP2-3-Display-Subsystem-driver.patch;patch=1 \
28 file://dss2/0004-DSS2-OMAP-framebuffer-driver.patch;patch=1 \
29 file://dss2/0005-DSS2-Add-panel-drivers.patch;patch=1 \
30 file://dss2/0006-DSS2-HACK-Add-DSS2-support-for-N800.patch;patch=1 \
31 file://dss2/0007-DSS2-Add-DSS2-support-for-SDP-Beagle-Overo-EVM.patch;patch=1 \
32 file://dss2/0008-DSS2-Add-function-to-display-object-to-get-the-back.patch;patch=1 \
33 file://dss2/0009-DSS2-Add-acx565akm-panel.patch;patch=1 \
34 file://dss2/0010-DSS2-Small-VRFB-context-allocation-bug-fixed.patch;patch=1 \
35 file://dss2/0011-DSS2-Allocated-memory-for-Color-Look-up-table.patch;patch=1 \
36 file://dss2/0012-DSS2-Fix-DMA-rotation.patch;patch=1 \
37 file://dss2/0013-DSS2-Verify-that-overlay-paddr-0.patch;patch=1 \
38 file://dss2/0014-DSS2-Add-function-to-get-DSS-logic-clock-rate.patch;patch=1 \
39 file://dss2/0015-DSS2-DSI-calculate-VP_CLK_RATIO-properly.patch;patch=1 \
40 file://dss2/0016-DSS2-DSI-improve-packet-len-calculation.patch;patch=1 \
41 file://dss2/0017-DSS2-Disable-video-planes-on-sync-lost-error.patch;patch=1 \
42 file://dss2/0018-DSS2-check-for-ovl-paddr-only-when-enabling.patch;patch=1 \
43 file://dss2/0019-DSS2-Check-fclk-limits-when-configuring-video-plane.patch;patch=1 \
44 file://dss2/0020-DSS2-Check-scaling-limits-against-proper-values.patch;patch=1 \
45 file://dss2/0021-DSS2-Add-venc-register-dump.patch;patch=1 \
46 file://dss2/0022-DSS2-FB-remove-unused-var-warning.patch;patch=1 \
47 file://dss2/0023-DSS2-pass-the-default-FB-color-format-through-board.patch;patch=1 \
48 file://dss2/0024-DSS2-Beagle-Use-gpio_set_value.patch;patch=1 \
49 file://dss2/0025-DSS2-VRFB-Macro-for-calculating-base-address-of-th.patch;patch=1 \
50 file://dss2/0026-DSS2-DSI-sidlemode-to-noidle-while-sending-frame.patch;patch=1 \
51 file://dss2/0027-DSS2-VRFB-rotation-and-mirroring-implemented.patch;patch=1 \
52 file://dss2/0028-DSS2-OMAPFB-Added-support-for-the-YUV-VRFB-rotatio.patch;patch=1 \
53 file://dss2/0029-DSS2-OMAPFB-Set-line_length-correctly-for-YUV-with.patch;patch=1 \
54 file://dss2/0030-DSS2-dispc_get_trans_key-was-returning-wrong-key-ty.patch;patch=1 \
55 file://dss2/0031-DSS2-do-bootmem-reserve-for-exclusive-access.patch;patch=1 \
56 file://dss2/0032-DSS2-Fix-DISPC_VID_FIR-value-for-omap34xx.patch;patch=1 \
57 file://dss2/0033-DSS2-Prefer-3-tap-filter.patch;patch=1 \
58 file://dss2/0034-DSS2-VRAM-improve-omap_vram_add_region.patch;patch=1 \
59 file://dss2/0035-DSS2-Added-the-function-pointer-for-getting-default.patch;patch=1 \
60 file://dss2/0036-DSS2-Added-support-for-setting-and-querying-alpha-b.patch;patch=1 \
61 file://dss2/0037-DSS2-Added-support-for-querying-color-keying.patch;patch=1 \
62 file://dss2/0038-DSS2-OMAPFB-Some-color-keying-pointerd-renamed-in-D.patch;patch=1 \
63 file://dss2/0039-DSS2-Add-sysfs-entry-to-for-the-alpha-blending-supp.patch;patch=1 \
64 file://dss2/0040-DSS2-Provided-proper-exclusion-for-destination-colo.patch;patch=1 \
65 file://dss2/0041-DSS2-Disable-vertical-offset-with-fieldmode.patch;patch=1 \
66 file://dss2/0042-DSS2-Don-t-enable-fieldmode-automatically.patch;patch=1 \
67 file://dss2/0043-DSS2-Swap-field-0-and-field-1-registers.patch;patch=1 \
68 file://dss2/0044-DSS2-add-sysfs-entry-for-seting-the-rotate-type.patch;patch=1 \
69 file://dss2/0045-DSS2-Fixed-line-endings-from-to.patch;patch=1 \
70 file://dss2/0046-DSS2-DSI-decrease-sync-timeout-from-60s-to-2s.patch;patch=1 \
71 file://dss2/0047-DSS2-fix-return-value-for-rotate_type-sysfs-functio.patch;patch=1 \
72 file://dss2/0048-OMAP2-3-DMA-implement-trans-copy-and-const-fill.patch;patch=1 \
73 file://dss2/0049-DSS2-VRAM-clear-allocated-area-with-DMA.patch;patch=1 \
74 file://dss2/0050-DSS2-OMAPFB-remove-fb-clearing-code.patch;patch=1 \
75 file://dss2/0051-DSS2-VRAM-use-debugfs-not-procfs.patch;patch=1 \
76 file://dss2/0052-DSS2-VRAM-fix-section-mismatch-warning.patch;patch=1 \
77 file://dss2/0053-DSS2-disable-LCD-DIGIT-before-resetting-DSS.patch;patch=1 \
78 file://0001-board-ldp-add-regulator-info-to-get-the-microSD-slo.patch;patch=1 \
79 file://fix-unaligned-access.diff;patch=1 \
80 file://make-alignment-visible.diff;patch=1 \
81 file://mmctiming.patch;patch=1 \
82 file://ehci.patch;patch=1 \
83 file://fix-audio-capture.patch;patch=1 \
84 file://ads7846-detection.patch;patch=1 \
85 file://musb/0001-USB-musb-only-turn-off-vbus-in-OTG-hosts.patch;patch=1 \
86 file://musb/0002-USB-composite-avoid-inconsistent-lock-state.patch;patch=1 \
87 file://musb/0003-USB-musb-NAK-timeout-scheme-on-bulk-RX-endpoint.patch;patch=1 \
88 file://musb/0004-USB-musb-rewrite-host-periodic-endpoint-allocation.patch;patch=1 \
89 file://musb/0005-USB-TWL-disable-VUSB-regulators-when-cable-unplugg.patch;patch=1 \
90 file://musb/0006-USB-gadget-composite-device-level-suspend-resume-h.patch;patch=1 \
91 file://musb/0007-usb-gadget-fix-ethernet-link-reports-to-ethtool.patch;patch=1 \
92 file://musb/0008-usb-musb_host-minor-enqueue-locking-fix-v2.patch;patch=1 \
93 file://musb/0009-usb-musb_host-fix-ep0-fifo-flushing.patch;patch=1 \
94 file://musb/0010-musb-sanitize-clearing-TXCSR-DMA-bits-take-2.patch;patch=1 \
95 file://musb/0011-musb-fix-isochronous-TXDMA-take-2.patch;patch=1 \
96 file://musb/0012-musb-fix-possible-panic-while-resuming.patch;patch=1 \
97 file://musb/0013-musb_host-refactor-musb_save_toggle-take-2.patch;patch=1 \
98 file://musb/0014-musb_gadget-suppress-parasitic-TX-interrupts-with.patch;patch=1 \
99 file://musb/0015-musb_gadget-fix-unhandled-endpoint-0-IRQs.patch;patch=1 \
100 file://musb/0016-musb_host-factor-out-musb_ep_-get-set-_qh.patch;patch=1 \
101 file://musb/0017-musb_host-refactor-URB-giveback.patch;patch=1 \
102 file://musb/0018-musb-split-out-CPPI-interrupt-handler.patch;patch=1 \
103 file://musb/0019-musb_host-simplify-check-for-active-URB.patch;patch=1 \
104 file://musb/0020-musb_host-streamline-musb_cleanup_urb-calls.patch;patch=1 \
105 file://musb/0021-twl4030-usb-fix-minor-reporting-goofage.patch;patch=1 \
106 file://musb/0022-musb-use-dma-mode-1-for-TX-if-transfer-size-equals.patch;patch=1 \
107 file://musb/0023-musb-add-high-bandwidth-ISO-support.patch;patch=1 \
108 file://musb/0024-USB-otg-adding-nop-usb-transceiver.patch;patch=1 \
109 file://musb/0025-nop-usb-xceiv-behave-when-linked-as-a-module.patch;patch=1 \
110 file://musb/0026-musb-proper-hookup-to-transceiver-drivers.patch;patch=1 \
111 file://musb/0027-musb-otg-timer-cleanup.patch;patch=1 \
112 file://musb/0028-musb-make-initial-HNP-roleswitch-work-v2.patch;patch=1 \
113 file://musb/0029-musb-support-disconnect-after-HNP-roleswitch.patch;patch=1 \
114 file://isp/v4l/0001-V4L2-Add-COLORFX-user-control.patch;patch=1 \
115 file://isp/v4l/0002-V4L-Int-if-v4l2_int_device_try_attach_all-requires.patch;patch=1 \
116 file://isp/v4l/0003-V4L-Int-if-Dummy-slave.patch;patch=1 \
117 file://isp/v4l/0004-V4L-int-device-add-support-for-VIDIOC_QUERYMENU.patch;patch=1 \
118 file://isp/v4l/0005-V4L-Int-if-Add-vidioc_int_querycap.patch;patch=1 \
119 file://isp/iommu/0001-omap-iommu-tlb-and-pagetable-primitives.patch;patch=1 \
120 file://isp/iommu/0002-omap-iommu-omap2-architecture-specific-functions.patch;patch=1 \
121 file://isp/iommu/0003-omap-iommu-omap3-iommu-device-registration.patch;patch=1 \
122 file://isp/iommu/0004-omap-iommu-simple-virtual-address-space-management.patch;patch=1 \
123 file://isp/iommu/0005-omap-iommu-entries-for-Kconfig-and-Makefile.patch;patch=1 \
124 file://isp/iommu/0006-omap-iommu-Don-t-try-BUG_ON-in_interrupt.patch;patch=1 \
125 file://isp/iommu/0007-omap-iommu-We-support-chained-scatterlists-probabl.patch;patch=1 \
126 file://isp/iommu/0008-omap2-iommu-entries-for-Kconfig-and-Makefile.patch;patch=1 \
127 file://isp/omap3camera/0001-omap3isp-Add-ISP-main-driver-and-register-definitio.patch;patch=1 \
128 file://isp/omap3camera/0002-omap3isp-Add-ISP-MMU-wrapper.patch;patch=1 \
129 file://isp/omap3camera/0003-omap3isp-Add-userspace-header.patch;patch=1 \
130 file://isp/omap3camera/0004-omap3isp-Add-ISP-frontend-CCDC.patch;patch=1 \
131 file://isp/omap3camera/0005-omap3isp-Add-ISP-backend-PRV-and-RSZ.patch;patch=1 \
132 file://isp/omap3camera/0006-omap3isp-Add-statistics-collection-modules-H3A-and.patch;patch=1 \
133 file://isp/omap3camera/0007-omap3isp-Add-CSI2-interface-support.patch;patch=1 \
134 file://isp/omap3camera/0008-omap3isp-Add-ISP-tables.patch;patch=1 \
135 file://isp/omap3camera/0009-omap34xxcam-Add-camera-driver.patch;patch=1 \
136# file://isp/base/0001-omap3-Add-base-address-definitions-and-resources-fo.patch;patch=1 \
137# file://isp/standalone/0001-Resizer-and-Previewer-driver-added-to-commit.patch;patch=1 \
138# file://isp/standalone/0002-Resizer-bug-fixes-on-top-of-1.0.2-release.patch;patch=1 \
139 file://0124-leds-gpio-broken-with-current-git.patch;patch=1 \
140 file://modedb-hd720.patch;patch=1 \
141"
142
143
144SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
145 file://beagle-asoc.patch;patch=1 \
146"
147
148SRC_URI_append_omap3evm = " \
149 file://evm-mcspi-ts.diff;patch=1 \
150"
151
152
153
154S = "${WORKDIR}/git"
155
156
157module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
158
159