summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-kernel/linux/linux-omap3-pm_git.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-omap3-pm_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-omap3-pm_git.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-omap3-pm_git.bb b/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
new file mode 100644
index 0000000000..45bc492d8e
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
@@ -0,0 +1,67 @@
1DESCRIPTION = "Linux Kernel"
2SECTION = "kernel"
3LICENSE = "GPL"
4
5inherit kernel
6
7FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PN}-git/${MACHINE}"
8
9SRCREV = "${AUTOREV}"
10
11PV = "2.6.31-rc7+pm+${PR}+git${SRCREV}"
12PR = "r3"
13
14SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;branch=pm;protocol=git"
15
16SRC_URI_append_zoom2 = " \
17 file://0001-OMAP1-2-3-4-DEBUG_LL-cleanup.patch;patch=1 \
18 file://0002-OMAP1-2-3-4-Adapt-board-files-for-cleand-DEBUG_LL-in.patch;patch=1 \
19 file://0003-OMAP-Zoom2-Add-DEBUG_LL-interface-using-external-Qua.patch;patch=1 \
20 "
21
22COMPATIBLE_MACHINE = "beagleboard|omap-3430sdp|omap3evm|overo|rx51|zoom2"
23
24S = "${WORKDIR}/git"
25
26do_configure_prepend() {
27 # logo support: if you supply logo_linux_clut224.ppm in SRC_URI,
28 # then it's going to be used instead of "Tux" in the kernel sources
29 if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
30 install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm \
31 drivers/video/logo/logo_linux_clut224.ppm
32 fi
33
34 # use the externally-supplied ${MACHINE}_external_defconfig if present,
35 # else use omap3_pm_defconfig from the sources
36 if [ -e ${WORKDIR}/${MACHINE}_external_defconfig ]; then
37 cp ${WORKDIR}/${MACHINE}_external_defconfig ${S}/arch/arm/configs/
38 yes '' | oe_runmake ${MACHINE}_external_defconfig
39 else
40 case ${MACHINE} in
41 omap-3430sdp | omap3evm)
42 # works out of the box
43 yes '' | oe_runmake omap3_pm_defconfig
44 ;;
45 beagleboard | overo | rx51)
46 # adjust LL_DEBUG console for these boards
47 yes '' | oe_runmake omap3_pm_defconfig
48 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
49 -e "s/# CONFIG_OMAP_LL_DEBUG_UART3 is not set/CONFIG_OMAP_LL_DEBUG_UART3=y/" \
50 -e "s/CONFIG_MMC_BLOCK=m/CONFIG_MMC_BLOCK=y/" \
51 -e "s/CONFIG_MMC_OMAP_HS=m/CONFIG_MMC_OMAP_HS=y/" \
52 -i ${S}/.config
53 ;;
54 zoom2)
55 # adjust LL_DEBUG console for this board
56 yes '' | oe_runmake omap3_pm_defconfig
57 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
58 -i ${S}/.config
59 echo "CONFIG_OMAP_LL_DEBUG_UART_EXT=y" >> ${S}/.config
60 ;;
61 *)
62 # its worth a try...
63 yes '' | oe_runmake ${MACHINE}_defconfig
64 ;;
65 esac
66 fi
67}