summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-18 15:32:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-18 15:36:06 +0000
commit673abd92f999829bdd67d0273c43570a62123a63 (patch)
tree63132d1ffc1cb5bf50d244b184ca8d58a9cbc85c /meta/recipes-kernel/linux/linux-omap3-pm_git.bb
parentfed61beb31c47e2d96af905a7047fe78d64c9bd0 (diff)
downloadpoky-673abd92f999829bdd67d0273c43570a62123a63.tar.gz
conf/machine: Drop older machines with no recent updates
These are all moving to meta-extras. Ideally in the future machines such as these will be maintained to topic specific layers as we move to a more layer oriented model. If this causes a problem for anyone please discuss it on the mailing list. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-omap3-pm_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-omap3-pm_git.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta/recipes-kernel/linux/linux-omap3-pm_git.bb b/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
deleted file mode 100644
index d65ca50415..0000000000
--- a/meta/recipes-kernel/linux/linux-omap3-pm_git.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1DESCRIPTION = "Linux Kernel"
2SECTION = "kernel"
3LICENSE = "GPL"
4
5inherit kernel
6
7FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/${PN}-git/${MACHINE}"
8
9PV = "2.6.31-rc7+pm+${PR}+git${SRCPV}"
10PR = "r3"
11
12SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-omap-pm.git;branch=pm;protocol=git"
13
14SRC_URI_append_zoom2 = " \
15 file://0001-OMAP1-2-3-4-DEBUG_LL-cleanup.patch;patch=1 \
16 file://0002-OMAP1-2-3-4-Adapt-board-files-for-cleand-DEBUG_LL-in.patch;patch=1 \
17 file://0003-OMAP-Zoom2-Add-DEBUG_LL-interface-using-external-Qua.patch;patch=1 \
18 "
19
20COMPATIBLE_MACHINE = "beagleboard|omap-3430sdp|omap3evm|overo|rx51|zoom2"
21
22S = "${WORKDIR}/git"
23
24do_configure_prepend() {
25 # logo support: if you supply logo_linux_clut224.ppm in SRC_URI,
26 # then it's going to be used instead of "Tux" in the kernel sources
27 if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
28 install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm \
29 drivers/video/logo/logo_linux_clut224.ppm
30 fi
31
32 # use the externally-supplied ${MACHINE}_external_defconfig if present,
33 # else use omap3_pm_defconfig from the sources
34 if [ -e ${WORKDIR}/${MACHINE}_external_defconfig ]; then
35 cp ${WORKDIR}/${MACHINE}_external_defconfig ${S}/arch/arm/configs/
36 yes '' | oe_runmake ${MACHINE}_external_defconfig
37 else
38 case ${MACHINE} in
39 omap-3430sdp | omap3evm)
40 # works out of the box
41 yes '' | oe_runmake omap3_pm_defconfig
42 ;;
43 beagleboard | overo | rx51)
44 # adjust LL_DEBUG console for these boards
45 yes '' | oe_runmake omap3_pm_defconfig
46 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
47 -e "s/# CONFIG_OMAP_LL_DEBUG_UART3 is not set/CONFIG_OMAP_LL_DEBUG_UART3=y/" \
48 -e "s/CONFIG_MMC_BLOCK=m/CONFIG_MMC_BLOCK=y/" \
49 -e "s/CONFIG_MMC_OMAP_HS=m/CONFIG_MMC_OMAP_HS=y/" \
50 -i ${S}/.config
51 ;;
52 zoom2)
53 # adjust LL_DEBUG console for this board
54 yes '' | oe_runmake omap3_pm_defconfig
55 sed -e "s/CONFIG_OMAP_LL_DEBUG_UART1=y/# CONFIG_OMAP_LL_DEBUG_UART1 is not set/" \
56 -i ${S}/.config
57 echo "CONFIG_OMAP_LL_DEBUG_UART_EXT=y" >> ${S}/.config
58 ;;
59 *)
60 # its worth a try...
61 yes '' | oe_runmake ${MACHINE}_defconfig
62 ;;
63 esac
64 fi
65}