diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2011-10-27 10:32:47 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-11-01 17:43:57 +0000 |
commit | 4950afe5756ace5801f445b0a8e94d8151c0ecb7 (patch) | |
tree | b24c7da2dcb6fcd48945d0ba38f8d21229d3fda3 /meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb | |
parent | 18ab6c98e4b3bb9b20f3c9bb81b1d58ffd8b143b (diff) | |
download | poky-4950afe5756ace5801f445b0a8e94d8151c0ecb7.tar.gz |
linux-libc-headers: factor common code into linux-libc-headers.inc
Each time a new linux-libc-headers is created the same code is
cloned. Placing the common functionality in the .inc file simplies
each recipe and make maintenance easier.
(From OE-Core rev: ccf3bf70a1a83ac55e47acfa4759838f7f4834ae)
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb')
-rw-r--r-- | meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb | 49 |
1 files changed, 1 insertions, 48 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb index 14f5e8a1ae..36cfb4fcab 100644 --- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb +++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers_2.6.39.bb | |||
@@ -1,54 +1,7 @@ | |||
1 | require linux-libc-headers.inc | 1 | require linux-libc-headers.inc |
2 | 2 | ||
3 | INHIBIT_DEFAULT_DEPS = "1" | 3 | PR = "r3" |
4 | DEPENDS += "unifdef-native" | ||
5 | 4 | ||
6 | SRC_URI += " file://connector-msg-size-fix.patch" | 5 | SRC_URI += " file://connector-msg-size-fix.patch" |
7 | SRC_URI[md5sum] = "1aab7a741abe08d42e8eccf20de61e05" | 6 | SRC_URI[md5sum] = "1aab7a741abe08d42e8eccf20de61e05" |
8 | SRC_URI[sha256sum] = "584d17f2a3ee18a9501d7ff36907639e538cfdba4529978b8550c461d45c61f6" | 7 | SRC_URI[sha256sum] = "584d17f2a3ee18a9501d7ff36907639e538cfdba4529978b8550c461d45c61f6" |
9 | |||
10 | S = "${WORKDIR}/linux-${PV}" | ||
11 | |||
12 | PR = "r2" | ||
13 | |||
14 | set_arch() { | ||
15 | case ${TARGET_ARCH} in | ||
16 | alpha*) ARCH=alpha ;; | ||
17 | arm*) ARCH=arm ;; | ||
18 | cris*) ARCH=cris ;; | ||
19 | hppa*) ARCH=parisc ;; | ||
20 | i*86*) ARCH=i386 ;; | ||
21 | ia64*) ARCH=ia64 ;; | ||
22 | mips*) ARCH=mips ;; | ||
23 | m68k*) ARCH=m68k ;; | ||
24 | powerpc*) ARCH=powerpc ;; | ||
25 | s390*) ARCH=s390 ;; | ||
26 | sh*) ARCH=sh ;; | ||
27 | sparc64*) ARCH=sparc64 ;; | ||
28 | sparc*) ARCH=sparc ;; | ||
29 | x86_64*) ARCH=x86_64 ;; | ||
30 | avr32*) ARCH=avr32 ;; | ||
31 | bfin*) ARCH=blackfin ;; | ||
32 | microblaze*) ARCH=microblaze ;; | ||
33 | esac | ||
34 | } | ||
35 | |||
36 | do_configure() { | ||
37 | set_arch | ||
38 | oe_runmake allnoconfig ARCH=$ARCH | ||
39 | } | ||
40 | |||
41 | do_compile () { | ||
42 | } | ||
43 | |||
44 | do_install() { | ||
45 | set_arch | ||
46 | oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH | ||
47 | # Kernel should not be exporting this header | ||
48 | rm -f ${D}${exec_prefix}/include/scsi/scsi.h | ||
49 | |||
50 | # The ..install.cmd conflicts between various configure runs | ||
51 | find ${D}${includedir} -name ..install.cmd | xargs rm -f | ||
52 | } | ||
53 | |||
54 | BBCLASSEXTEND = "nativesdk" | ||