summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_git.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-10-27 13:24:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-04 10:27:11 +0000
commit9adfa08360297670489304213debad514ad17f92 (patch)
treeac87320d5271c71db99d8b6b40a090cf78a9f4d9 /meta/recipes-kernel/kmod/kmod_git.bb
parent028a39431e466299975570cb0bf9e304f769bb20 (diff)
downloadpoky-9adfa08360297670489304213debad514ad17f92.tar.gz
kmod: fix debuginfo is missing in shared library
INHIBIT_PACKAGE_STRIP variable will make debuginfo lose in shared library. The test cases of kmod contain kernel modules for many different architectures, strip and arch gets confused and throws errors. Pack kernel modules in test cases to avoid strip command failed. (From OE-Core rev: 3576399ed163cb3136ee1a2077622035d2033158) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index d4c21a4387..08dd81569c 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -34,6 +34,10 @@ do_install_append () {
34 # install depmod.d file for search/ dir 34 # install depmod.d file for search/ dir
35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf" 35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
36 36
37 if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
38 find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
39 find testsuite -name *.ko -exec rm -f {} \;
40 fi
37} 41}
38 42
39do_compile_prepend() { 43do_compile_prepend() {
@@ -44,7 +48,10 @@ do_compile_ptest () {
44 oe_runmake buildtest-TESTS rootfs 48 oe_runmake buildtest-TESTS rootfs
45} 49}
46 50
47INHIBIT_PACKAGE_STRIP = "${@bb.utils.contains("DISTRO_FEATURES", "ptest", "1", "0", d)}" 51do_install_ptest () {
52 install testmodule.tar ${D}${PTEST_PATH}
53}
54
48INSANE_SKIP_${PN}-ptest = "arch" 55INSANE_SKIP_${PN}-ptest = "arch"
49 56
50inherit update-alternatives 57inherit update-alternatives