summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_git.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-04-13 09:55:04 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-15 14:19:44 +0100
commit7ad628e0ef3817532916df090cc98672341415bb (patch)
treecf9ce0b14c352be624e63d90e902072dfc22853c /meta/recipes-kernel/kmod/kmod_git.bb
parent710b01e01e670c00b60587443d56025a4ba81c33 (diff)
downloadpoky-7ad628e0ef3817532916df090cc98672341415bb.tar.gz
kmod: upgrade to 20
The following patches are rebased. -- Change-to-calling-bswap_-instead-of-htobe-and-be-toh.patch -- avoid_parallel_tests.patch The ptest part of kmod is removed because new version of kmod port all tests to use modules from module-playground instead of copying prebuilt modules to the repository. So, we cannot use ptest as before. Remove it so that kmod can build successfully. (From OE-Core rev: f80d136bdd578468035a88125fa1b84973fd912b) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index 08dd81569c..ba4d85eda4 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -33,27 +33,12 @@ do_install_append () {
33 33
34 # install depmod.d file for search/ dir 34 # install depmod.d file for search/ dir
35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf" 35 install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
36
37 if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
38 find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
39 find testsuite -name *.ko -exec rm -f {} \;
40 fi
41} 36}
42 37
43do_compile_prepend() { 38do_compile_prepend() {
44 sed -i 's/ac_pwd=/#ac_pwd=/' config.status ; sed -i "/#ac_pwd=/a\ac_pwd='.'" config.status 39 sed -i 's/ac_pwd=/#ac_pwd=/' config.status ; sed -i "/#ac_pwd=/a\ac_pwd='.'" config.status
45} 40}
46 41
47do_compile_ptest () {
48 oe_runmake buildtest-TESTS rootfs
49}
50
51do_install_ptest () {
52 install testmodule.tar ${D}${PTEST_PATH}
53}
54
55INSANE_SKIP_${PN}-ptest = "arch"
56
57inherit update-alternatives 42inherit update-alternatives
58 43
59ALTERNATIVE_PRIORITY = "60" 44ALTERNATIVE_PRIORITY = "60"