summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-17 16:33:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-28 09:25:15 +0000
commit503c08d5207d4af777a40e9f124b280ce115c4f2 (patch)
treee8fafbf9e6c7c9c40def29587b612ca04c39da4a /meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
parent4fa2e4b28d3b45ce66a92d8bb9b0b32bfcd31ed5 (diff)
downloadpoky-503c08d5207d4af777a40e9f124b280ce115c4f2.tar.gz
kexec-tools: update to 2.0.11
(From OE-Core rev: d515df2d73defb73eb87b9df1b163a161c3e6e4e) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb')
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb b/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
new file mode 100644
index 0000000000..717376703f
--- /dev/null
+++ b/meta/recipes-kernel/kexec/kexec-tools_2.0.11.bb
@@ -0,0 +1,30 @@
1require kexec-tools.inc
2export LDFLAGS = "-L${STAGING_LIBDIR}"
3EXTRA_OECONF = " --with-zlib=yes"
4
5SRC_URI += "file://kexec-tools-Refine-kdump-device_tree-sort.patch \
6 file://kexec-aarch64.patch \
7 file://kexec-x32.patch \
8 file://0002-powerpc-change-the-memory-size-limit.patch \
9 file://0001-purgatory-Pass-r-directly-to-linker.patch \
10 "
11
12SRC_URI[md5sum] = "86de066859f289048f1b286af6f03f78"
13SRC_URI[sha256sum] = "84f652ebf1de3f7b9de757a50cdbf6d5639d88c1d5b5ef9f525edde5ef9590c2"
14
15PACKAGES =+ "kexec kdump vmcore-dmesg"
16
17ALLOW_EMPTY_${PN} = "1"
18RRECOMMENDS_${PN} = "kexec kdump vmcore-dmesg"
19
20FILES_${PN} =+ "${sysconfig}/init.d/kdump ${sysconfig}/sysconfig/kdump.conf"
21FILES_kexec = "${sbindir}/kexec"
22FILES_kdump = "${sbindir}/kdump"
23FILES_vmcore-dmesg = "${sbindir}/vmcore-dmesg"
24
25do_install_append () {
26 install -d ${D}${sysconfdir}/init.d
27 install -m 0755 ${WORKDIR}/kdump ${D}${sysconfdir}/init.d/kdump
28 install -d ${D}${sysconfdir}/sysconfig
29 install -m 0644 ${WORKDIR}/kdump.conf ${D}${sysconfdir}/sysconfig
30}