summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-03-01 14:18:32 -0800
committerSaul Wold <sgw@linux.intel.com>2011-03-04 14:34:31 -0800
commit1b11ff7752122dd3f162fc08a80f8ddeb568c11d (patch)
treea3ecafe8b6125be62a6f15e15de550cc5499ce8e /meta/recipes-kernel/hello-mod/hello-mod_0.1.bb
parent101ce7109eee3af44d2e4999085d6dfcfd782587 (diff)
downloadpoky-1b11ff7752122dd3f162fc08a80f8ddeb568c11d.tar.gz
hello-mod: add a module for testing module.bbclass
The following patch creates a hello-mod recipe for building a trivial out-of-tree kernel module, hello-mod.ko. This demonstrates the hostprogs build modifications added to module.bbclass. When loaded and unloaded, the module prints a simple string to the console to demonstrate it was compiled correctly. Tested on qemux86 poky-image-sato and beagleboard poky-image-minimal (after adding hello-mod to the images). (From OE-Core rev: d4765569d51448e8918bb15e7ab342983344074a) Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/hello-mod/hello-mod_0.1.bb')
-rw-r--r--meta/recipes-kernel/hello-mod/hello-mod_0.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb
new file mode 100644
index 0000000000..bbd4984cd6
--- /dev/null
+++ b/meta/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "hello-world-mod tests the module.bbclass mechanism."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4
5inherit module
6
7PR = r0
8PV = "0.1"
9
10SRC_URI = "file://Makefile \
11 file://hello.c \
12 file://COPYING \
13 "
14
15S = "${WORKDIR}"