summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-tests_1.9.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2017-07-12 03:15:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-21 22:51:37 +0100
commitbfd831a8695e6b4e2095deb286014172a6bf5051 (patch)
treee677308dd5cfef33a4f6ebca74a25fa4f28220d2 /meta/recipes-kernel/cryptodev/cryptodev-tests_1.9.bb
parentd2990a2da61b6a6078728cfa3715b3f4144398f7 (diff)
downloadpoky-bfd831a8695e6b4e2095deb286014172a6bf5051.tar.gz
cryptodev: 1.8 -> 1.9
* Remove backported patch: - 0001-Adjust-to-another-change-in-the-user-page-API.patch - 06d6b560c6e45dc317dae47c74706fa43f4a31d8.patch - cb186f682679383e8b5806240927903730ce85d9.patch - kernel-4-10-changes.patch * Update patch: - 0001-Disable-installing-header-file-provided-by-another-p.patch * Update FILES_${PN} since there are files in bindir: /usr/bin/hmac_comp /usr/bin/cipher_comp /usr/bin/async_hmac /usr/bin/cipher-aead-srtp /usr/bin/hash_comp /usr/bin/async_speed /usr/bin/async_cipher /usr/bin/sha_speed /usr/bin/hashcrypt_speed /usr/bin/hmac /usr/bin/cipher-gcm /usr/bin/cipher /usr/bin/fullspeed /usr/bin/speed /usr/bin/cipher-aead (From OE-Core rev: 27202954ce7abda22f7e81c2d72a80f0fa7006d8) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-tests_1.9.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-tests_1.9.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.9.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.9.bb
new file mode 100644
index 0000000000..9cb5dcb94f
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.9.bb
@@ -0,0 +1,21 @@
1require cryptodev.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS += "openssl"
6
7SRC_URI += " \
8file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
9"
10
11EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
12
13do_compile() {
14 oe_runmake testprogs
15}
16
17do_install() {
18 oe_runmake install_tests
19}
20
21FILES_${PN} = "${bindir}/*"