summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-20 01:09:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-21 07:20:24 +0100
commit04419c189e86f38331865de9480eab8f7d9528c3 (patch)
tree16fab4da68212f5a19bdfabdc833ab3cfeda0007 /meta/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
parent6184951031340cee648ea3eba20d10dd2b897ac3 (diff)
downloadpoky-04419c189e86f38331865de9480eab8f7d9528c3.tar.gz
cryptodev: 1.6 -> 1.7
* Remove 0002-In-the-3.13-rc1-Linux-kernel-the-INIT_COMPLETION-mac.patch since it was a backported patch. * Updated 0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch. (From OE-Core rev: 9347311ca444c3128653c96f9f2845713c646fa7) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
new file mode 100644
index 0000000000..a33841d091
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
@@ -0,0 +1,13 @@
1require cryptodev_${PV}.inc
2
3SUMMARY = "A /dev/crypto device driver header file"
4
5do_compile[noexec] = "1"
6
7# Just install cryptodev.h which is the only header file needed to be exported
8do_install() {
9 install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
10}
11
12ALLOW_EMPTY_${PN} = "1"
13BBCLASSEXTEND = "native nativesdk"