summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-02-15 11:22:18 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-15 16:05:37 +0000
commita541ddddea22dad134266b55301e675c5e810d0c (patch)
tree5500a00cbc2fbe5a467e21435fd89051f1bf6d12 /meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
parent9025bd11ec494709242ec5d22b245155c497741f (diff)
downloadpoky-a541ddddea22dad134266b55301e675c5e810d0c.tar.gz
cryptodev: 1.9 -> 1.10
* Remove backported patches: 0001-Port-tests-to-openssl-1.1.patch 0001-ioctl.c-Fix-build-with-linux-4.13.patch 0001-ioctl.c-Fix-build-with-linux-4.17.patch 0001-refactoring-split-big-function-to-simplify-maintaina.patch 0002-refactoring-relocate-code-to-simplify-later-patches.patch 0003-convert-to-new-AEAD-interface-in-kernels-v4.2.patch (From OE-Core rev: bc7e91cd2eef6f01670ef30a9ed0e077f3844d7d) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
new file mode 100644
index 0000000000..c55577c661
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.10.bb
@@ -0,0 +1,13 @@
1require cryptodev.inc
2
3SUMMARY = "A /dev/crypto device driver header file"
4
5do_compile[noexec] = "1"
6
7# Just install cryptodev.h which is the only header file needed to be exported
8do_install() {
9 install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
10}
11
12ALLOW_EMPTY_${PN} = "1"
13BBCLASSEXTEND = "native nativesdk"