summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2018-04-03 18:49:10 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:03 +0100
commit0971f7f1645f879a5084f34bec409c42fccbb5c6 (patch)
tree5374179b4592fe0be17b34464a6f21e248553c8b /meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb
parentca0a42695375fd43357ee753ae9c013128153391 (diff)
downloadpoky-0971f7f1645f879a5084f34bec409c42fccbb5c6.tar.gz
xcb-proto: update to 1.13
drop patches included in update (From OE-Core rev: f5341f043ed63db717c74677ff831fd5de7ce7ef) Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb')
-rw-r--r--meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb b/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb
new file mode 100644
index 0000000000..d5037868d5
--- /dev/null
+++ b/meta/recipes-graphics/xorg-proto/xcb-proto_1.13.bb
@@ -0,0 +1,51 @@
1SUMMARY = "XCB: The X protocol C binding headers"
2DESCRIPTION = "Function prototypes for the X protocol C-language Binding \
3(XCB). XCB is a replacement for Xlib featuring a small footprint, \
4latency hiding, direct access to the protocol, improved threading \
5support, and extensibility."
6HOMEPAGE = "http://xcb.freedesktop.org"
7BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
8
9SECTION = "x11/libs"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7 \
12 file://src/dri2.xml;beginline=2;endline=28;md5=f8763b13ff432e8597e0d610cf598e65"
13
14SRC_URI = "http://xcb.freedesktop.org/dist/${BP}.tar.bz2"
15
16SRC_URI[md5sum] = "abe9aa4886138150bbc04ae4f29b90e3"
17SRC_URI[sha256sum] = "7b98721e669be80284e9bbfeab02d2d0d54cd11172b72271e47a2fe875e2bde1"
18
19inherit autotools pkgconfig
20
21# Force the use of Python 3 and a specific library path so we don't need to
22# depend on python3-native
23CACHED_CONFIGUREVARS += "PYTHON=python3 am_cv_python_pythondir=${libdir}/xcb-proto"
24
25PACKAGES += "python-xcbgen"
26
27FILES_${PN} = ""
28FILES_${PN}-dev += "${datadir}/xcb/*.xml ${datadir}/xcb/*.xsd"
29FILES_python-xcbgen = "${libdir}/xcb-proto"
30
31RDEPENDS_${PN}-dev = ""
32RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"
33
34BBCLASSEXTEND = "native nativesdk"
35
36# Need to do this dance because we're forcing the use of host Python above and
37# if xcb-proto is built with Py3.5 and then re-used from sstate on a host with
38# Py3.6 the second build will write new cache files into the sysroot which won't
39# be listed in the manifest so won't be deleted, resulting in an error on
40# rebuilds. Solve this by deleting the entire cache directory when this package
41# is removed from the sysroot.
42SSTATEPOSTINSTFUNCS += "xcb_sstate_postinst"
43xcb_sstate_postinst() {
44 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
45 then
46 cat <<EOF >${SSTATE_INST_POSTRM}
47#!/bin/sh
48rm -rf ${libdir}/xcb-proto/xcbgen/__pycache__
49EOF
50 fi
51}