summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxt_1.1.2.bb
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2012-03-15 21:00:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-21 15:31:55 +0000
commitbef3721bd75b8016382f78016081dfdd3cbb42a9 (patch)
tree17e300069e09df7a2ac7dad644f5ea4801db5c56 /meta/recipes-graphics/xorg-lib/libxt_1.1.2.bb
parent04e49552e3ae6a0c65608f3ebf70c3d2d6d24a22 (diff)
downloadpoky-bef3721bd75b8016382f78016081dfdd3cbb42a9.tar.gz
libxt: upgrade to 1.1.2
(From OE-Core rev: b61972beebab8cef38d68aca11c0d960e601f744) Signed-off-by: Shane Wang <shane.wang@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxt_1.1.2.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxt_1.1.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxt_1.1.2.bb b/meta/recipes-graphics/xorg-lib/libxt_1.1.2.bb
new file mode 100644
index 0000000000..04fd59d9ed
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxt_1.1.2.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Xt: X Toolkit Intrinsics library"
2
3DESCRIPTION = "The Intrinsics are a programming library tailored to the \
4special requirements of user interface construction within a network \
5window system, specifically the X Window System. The Intrinsics and a \
6widget set make up an X Toolkit. The Intrinsics provide the base \
7mechanism necessary to build a wide variety of interoperating widget \
8sets and application environments. The Intrinsics are a layer on top of \
9Xlib, the C Library X Interface. They extend the fundamental \
10abstractions provided by the X Window System while still remaining \
11independent of any particular user interface policy or style."
12
13require xorg-lib-common.inc
14
15LICENSE = "MIT & MIT-style"
16LIC_FILES_CHKSUM = "file://COPYING;md5=3239170e81427c5948287df07691f03f"
17
18
19DEPENDS += "util-linux libxcb libsm virtual/libx11 kbproto libxdmcp"
20PROVIDES = "xt"
21
22PR = "r0"
23PE = "1"
24
25XORG_PN = "libXt"
26
27SRC_URI += "file://libxt_fix_for_x32.patch"
28
29BBCLASSEXTEND = "native"
30
31EXTRA_OECONF += "--disable-install-makestrs --disable-xkb"
32
33do_compile() {
34 (
35 unset CC LD CXX CCLD CFLAGS
36 oe_runmake -C util 'XT_CFLAGS=' 'CC=${BUILD_CC}' 'LD=${BUILD_LD}' 'CXX=${BUILD_CXX}' 'CCLD=${BUILD_CCLD}' 'CFLAGS=-D_GNU_SOURCE -I${STAGING_INCDIR_NATIVE} ${BUILD_CFLAGS}' 'LDFLAGS=${BUILD_LDFLAGS}' 'CXXFLAGS=${BUILD_CXXFLAGS}' 'CPPFLAGS=${BUILD_CPPFLAGS}' makestrs
37 )
38 if [ "$?" != "0" ]; then
39 exit 1
40 fi
41 oe_runmake
42}
43
44SRC_URI[md5sum] = "c4f7f149559320f378d93b835d38ad6f"
45SRC_URI[sha256sum] = "f041a7802b13630348072f5a609e0cc0e3df2382c0ddaae41d2769422eacc347"