summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-04-30 11:58:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-03 15:41:39 +0100
commit2ed888f3e0be4ce59b825357132ea7599280f097 (patch)
tree63c965be70c67ddb56207f23d6626534242c9ede /meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
parent9bb49514abb6ecf6b12029228010a0c34829edc1 (diff)
downloadpoky-2ed888f3e0be4ce59b825357132ea7599280f097.tar.gz
libxcb: update to 1.14
Drop a patch as the problem is fixed upstream. (From OE-Core rev: bf4ef2e3b376744b16c2f57725104207d23c28c6) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb_1.14.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.14.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
new file mode 100644
index 0000000000..f27c5daa61
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.14.bb
@@ -0,0 +1,35 @@
1SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz \
13 file://disable-check.patch \
14 "
15
16SRC_URI[sha256sum] = "a55ed6db98d43469801262d81dc2572ed124edc3db31059d4e9916eb9f844c34"
17
18BBCLASSEXTEND = "native nativesdk"
19
20DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
21
22PACKAGES_DYNAMIC = "^libxcb-.*"
23
24FILES_${PN} = "${libdir}/libxcb.so.*"
25
26inherit autotools pkgconfig features_check
27
28# The libxau and others requires x11 in DISTRO_FEATURES
29REQUIRED_DISTRO_FEATURES = "x11"
30
31export PYTHON = "python3"
32
33python populate_packages_prepend () {
34 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
35}