summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb_1.13.1.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-10-20 18:39:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-14 11:14:38 +0000
commit1fe0a449afdb00ff571f38e70cbf68f3f9e786a5 (patch)
tree65f560c1e3d0508ed7a79214ccc428bcb439796c /meta/recipes-graphics/xorg-lib/libxcb_1.13.1.bb
parent60dcdbf6bf5b3d3bd05260846125bf89fb47d1f6 (diff)
downloadpoky-1fe0a449afdb00ff571f38e70cbf68f3f9e786a5.tar.gz
libxcb: update to 1.13.1
(From OE-Core rev: c3ecf470b0f4d681dd11c366e3fa903c6e13717e) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb_1.13.1.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.13.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.13.1.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.13.1.bb
new file mode 100644
index 0000000000..d8cee510ca
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.13.1.bb
@@ -0,0 +1,39 @@
1SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
13 file://xcbincludedir.patch \
14 file://disable-check.patch \
15 file://gcc-mips-pr68302-mips-workaround.patch \
16 "
17
18SRC_URI[md5sum] = "f33cdfc67346f7217a9326c0d8679975"
19SRC_URI[sha256sum] = "a89fb7af7a11f43d2ce84a844a4b38df688c092bf4b67683aef179cdf2a647c4"
20
21BBCLASSEXTEND = "native nativesdk"
22
23DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
24
25PACKAGES_DYNAMIC = "^libxcb-.*"
26
27FILES_${PN} = "${libdir}/libxcb.so.*"
28
29inherit autotools pkgconfig distro_features_check
30
31# The libxau and others requires x11 in DISTRO_FEATURES
32REQUIRED_DISTRO_FEATURES = "x11"
33REQUIRED_DISTRO_FEATURES_class-native = ""
34
35export PYTHON = "python3"
36
37python populate_packages_prepend () {
38 do_split_packages(d, '${libdir}', '^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
39}