summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-11-23 01:47:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-24 15:12:32 +0000
commitfb403f2952a42d441be432d4bd40257bb3c29bb9 (patch)
treeaff916c696e3d39eea46673d13cfb1420e71a7ad /meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
parent957b835f2a159aa293a77a4c947242b8bf89f8aa (diff)
downloadpoky-fb403f2952a42d441be432d4bd40257bb3c29bb9.tar.gz
xf86-video-omapfb: revive driver which actually works and is tested on real devices
* 0006-omapfb-port-to-new-xserver-video-API.patch added to port it to new xserver video API * other patches just updated headers to be able to git am them (From OE-Core rev: 58e600ae3cc955ebe30b2756540404a267c7cb26) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb b/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
new file mode 100644
index 0000000000..50ce4c2f9c
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-omapfb_git.bb
@@ -0,0 +1,33 @@
1require xorg-driver-video.inc
2
3SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
4
5DESCRIPTION = "omapfb driver supports the basic Texas Instruments OMAP \
6framebuffer."
7
8LICENSE = "MIT-X & GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=63e2cbac53863f60e2f43343fb34367f"
10DEPENDS += "virtual/libx11"
11
12SRCREV = "28c006c94e57ea71df11ec4fff79d7ffcfc4860f"
13PR = "${INC_PR}.7"
14PV = "0.1.1+gitr${SRCPV}"
15
16SRC_URI = "git://git.pingu.fi/xf86-video-omapfb;protocol=http \
17 file://0001-Revert-Set-a-large-CRTC-upper-limit-to-not-prune-lar.patch \
18 file://0002-Revert-Set-virtual-size-when-configuring-framebuffer.patch \
19 file://0003-force-plain-mode.patch \
20 file://0004-blacklist-tv-out.patch \
21 file://0005-Attempt-to-fix-VRFB.patch \
22 file://0006-omapfb-port-to-new-xserver-video-API.patch \
23"
24
25S = "${WORKDIR}/git"
26
27EXTRA_OECONF_armv7a = " --enable-neon "
28CFLAGS += " -I${STAGING_INCDIR}/xorg "
29
30# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
31do_compile_prepend_armv7a () {
32 sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c
33}