summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-12-12 12:11:47 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-13 22:55:21 +0000
commit8ddb6b4164b9b4501fe6c960777710255105c4d3 (patch)
tree3cb4c32880babb1447322ad6c0400c85d23ede9e /meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb
parentb21d15a1e838bd236d90b8b63b34c94ff11da16a (diff)
downloadpoky-8ddb6b4164b9b4501fe6c960777710255105c4d3.tar.gz
xf86-video-omap: Upgrade 0.4.4 -> 0.4.5
Support ABI 23. (From OE-Core rev: b95771f9fa113655d1b158e4e1fde0961bce460a) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb')
-rw-r--r--meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb b/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb
new file mode 100644
index 0000000000..e652394517
--- /dev/null
+++ b/meta/recipes-graphics/xorg-driver/xf86-video-omap_0.4.5.bb
@@ -0,0 +1,41 @@
1require xorg-driver-video.inc
2
3SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver"
4
5SUMMARY = "X.Org X server -- TI OMAP integrated graphics chipsets driver"
6
7DESCRIPTION = "Open-source X.org graphics driver for TI OMAP graphics \
8Currently relies on a closed-source submodule for EXA acceleration on \
9the following chipsets: \
10 + OMAP3430 \
11 + OMAP3630 \
12 + OMAP4430 \
13 + OMAP4460 \
14 + OMAP5430 \
15 + OMAP5432 \
16\
17NOTE: this driver is work in progress.. you probably don't want to try \
18and use it yet. The API/ABI between driver and kernel, and driver and \
19acceleration submodules is not stable yet. This driver requires the \
20omapdrm kernel driver w/ GEM support. \
21"
22
23LICENSE = "GPLv2+"
24LIC_FILES_CHKSUM = "file://COPYING;md5=10ce5de3b111315ea652a5f74ec0c602"
25DEPENDS += "virtual/libx11 libdrm xf86driproto"
26
27SRC_URI[md5sum] = "3b8ea5e8fba63355c0dc6681c49d5fe5"
28SRC_URI[sha256sum] = "93e7d42107521e61f61980eaea64fb452e87b7b94272e48938ac8d904ccfab5a"
29
30CFLAGS += " -I${STAGING_INCDIR}/xorg "
31
32# Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
33do_compile_prepend_armv7a () {
34 sed -i -e s:fb1:fb2:g ${S}/src/omap_xv.c
35}
36
37python () {
38 if not bb.utils.contains ('DISTRO_FEATURES', 'opengl', True, False, d):
39 raise bb.parse.SkipPackage("'opengl' not in DISTRO_FEATURES")
40}
41