summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-06-14 14:38:19 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-29 13:09:00 +0100
commit0a3d3b606e8991b0e76b3eec110ffc36a3430073 (patch)
treedc16ac3e4aee54ae14586205e917a38a2e7b5dc2 /meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
parent054b932f7bb8b9c49a5663dfb6f32ae90d4a6046 (diff)
downloadpoky-0a3d3b606e8991b0e76b3eec110ffc36a3430073.tar.gz
xinput-calibrator: move it from meta-oe to oe-core
People using xserver-xorg that need to calibrate their touchscreen devices would also need meta-oe. Bringing the recipes to oe-core will make it easier for them. Aditionaly: * drop xterm RDEPENDS. Terminal is not needed to run the menu item; * change xinput_calibrator_pointercal.sh so that it can be run as normal user: pointercal.xinput is saved to ~/.pointercal/ and it will be used when the system boots; * have the calibration run through an Xsession file; * remove the systemd service since calibration is run by Xsession; * do not install pointercal.xinput if it's the default one; [YOCTO #4416] (From OE-Core rev: 4ecafd89dbf41cbd53e6db32678fe625c06caaab) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb')
-rw-r--r--meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
new file mode 100644
index 0000000000..d0f07c9ad8
--- /dev/null
+++ b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "A generic touchscreen calibration program for X.Org"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/xinput_calibrator"
3LICENSE = "MIT-X"
4LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f34021557898e4b5a"
5DEPENDS = "virtual/libx11 libxi"
6
7PV = "0.7.5+git${SRCPV}"
8PR = "r6"
9
10inherit autotools
11
12SRCREV = "c01c5af807cb4b0157b882ab07a893df9a810111"
13SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git \
14 file://30xinput_calibrate.sh \
15 file://Allow-xinput_calibrator_pointercal.sh-to-be-run-as-n.patch"
16
17S = "${WORKDIR}/git"
18
19# force native X11 ui as we don't have gtk+ in DEPENDS
20EXTRA_OECONF += "--with-gui=x11"
21
22do_install_append() {
23 install -d ${D}${bindir}
24 install -m 0755 scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
25
26 install -d ${D}${sysconfdir}/X11/Xsession.d/
27 install -m 0755 ${WORKDIR}/30xinput_calibrate.sh ${D}${sysconfdir}/X11/Xsession.d/
28}
29
30RDEPENDS_${PN} = "xinput"
31RRECOMMENDS_${PN} = "pointercal-xinput"