diff options
author | Denys Dmytriyenko <denys@ti.com> | 2018-04-11 14:03:19 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-05-04 13:28:04 +0100 |
commit | 1b0340b3b888696cb3c0600884686678535a4e5b (patch) | |
tree | 9e8b70f1f4a8bcfbe391bb8b2ecda073d584b979 /meta/recipes-graphics/wayland/weston_4.0.0.bb | |
parent | 8097bf7012a0d97d3b8b48eceb5dc20cc4ae7ca9 (diff) | |
download | poky-1b0340b3b888696cb3c0600884686678535a4e5b.tar.gz |
weston: upgrade to 4.0.0
Official announcement:
https://lists.freedesktop.org/archives/wayland-devel/2018-April/037768.html
Dropped previously backported fix-missing-header.patch and
weston-gl-renderer-Set-pitch-correctly-for-subsampled-textures.patch
Refresh remaining local patches.
Modify 0001-weston-launch-Provide-a-default-version-that-doesn-t.patch with
changes to apply against the new code base.
Support for libunwind was dropped in bb707dc0fe331c9af112a0552b7aa6fde755dd83:
https://cgit.freedesktop.org/wayland/weston/commit/?id=bb707dc0fe331c9af112a0552b7aa6fde755dd83
Extract major version for referring to libweston-4 helper libraries.
(From OE-Core rev: 0cc82a9158f58a37865f3ccc56156c987706f735)
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_4.0.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_4.0.0.bb | 112 |
1 files changed, 112 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_4.0.0.bb b/meta/recipes-graphics/wayland/weston_4.0.0.bb new file mode 100644 index 0000000000..7dfca7fc63 --- /dev/null +++ b/meta/recipes-graphics/wayland/weston_4.0.0.bb | |||
@@ -0,0 +1,112 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \ | ||
6 | file://libweston/compositor.c;endline=26;md5=e342df749174a8ee11065583157c7a38" | ||
7 | |||
8 | SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://weston.png \ | ||
10 | file://weston.desktop \ | ||
11 | file://0001-make-error-portable.patch \ | ||
12 | file://xwayland.weston-start \ | ||
13 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "33709aa4d5916f89643fca0fc0064b39" | ||
16 | SRC_URI[sha256sum] = "a0fc0ae7ef83dfbed12abfe9b8096a24a7dd00705e86fa0db1e619ded18b4b58" | ||
17 | |||
18 | inherit autotools pkgconfig useradd distro_features_check | ||
19 | # depends on virtual/egl | ||
20 | REQUIRED_DISTRO_FEATURES = "opengl" | ||
21 | |||
22 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
23 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" | ||
24 | |||
25 | WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}" | ||
26 | |||
27 | EXTRA_OECONF = "--enable-setuid-install \ | ||
28 | --disable-rdp-compositor \ | ||
29 | " | ||
30 | EXTRA_OECONF_append_qemux86 = "\ | ||
31 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
32 | " | ||
33 | EXTRA_OECONF_append_qemux86-64 = "\ | ||
34 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
35 | " | ||
36 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ | ||
37 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ | ||
38 | ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd x11', d)} \ | ||
39 | clients launch" | ||
40 | # | ||
41 | # Compositor choices | ||
42 | # | ||
43 | # Weston on KMS | ||
44 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev" | ||
45 | # Weston on Wayland (nested Weston) | ||
46 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa" | ||
47 | # Weston on X11 | ||
48 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
49 | # Headless Weston | ||
50 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
51 | # Weston on framebuffer | ||
52 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
53 | # weston-launch | ||
54 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,drm" | ||
55 | # VA-API desktop recorder | ||
56 | PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva" | ||
57 | # Weston with EGL support | ||
58 | PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl" | ||
59 | # Weston with cairo glesv2 support | ||
60 | PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo" | ||
61 | # Weston with lcms support | ||
62 | PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms" | ||
63 | # Weston with webp support | ||
64 | PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp" | ||
65 | # Weston with systemd-login support | ||
66 | PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus" | ||
67 | # Weston with Xwayland support (requires X11 and Wayland) | ||
68 | PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland" | ||
69 | # colord CMS support | ||
70 | PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord" | ||
71 | # Clients support | ||
72 | PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients" | ||
73 | # Weston with PAM support | ||
74 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" | ||
75 | |||
76 | do_install_append() { | ||
77 | # Weston doesn't need the .la files to load modules, so wipe them | ||
78 | rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la | ||
79 | |||
80 | # If X11, ship a desktop file to launch it | ||
81 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then | ||
82 | install -d ${D}${datadir}/applications | ||
83 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
84 | |||
85 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
86 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
87 | fi | ||
88 | |||
89 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then | ||
90 | install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland | ||
91 | fi | ||
92 | } | ||
93 | |||
94 | PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \ | ||
95 | libweston-${WESTON_MAJOR_VERSION} ${PN}-examples" | ||
96 | |||
97 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}" | ||
98 | |||
99 | FILES_libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so" | ||
100 | SUMMARY_libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'." | ||
101 | |||
102 | FILES_${PN}-examples = "${bindir}/*" | ||
103 | |||
104 | FILES_${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so" | ||
105 | RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland" | ||
106 | |||
107 | RDEPENDS_${PN} += "xkeyboard-config" | ||
108 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
109 | RRECOMMENDS_${PN}-dev += "wayland-protocols" | ||
110 | |||
111 | USERADD_PACKAGES = "${PN}" | ||
112 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||