summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/weston_1.8.0.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-06-03 13:00:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-02 23:08:40 +0100
commit3ff474c64235579316c6fe104fd61af90062ac65 (patch)
treed64e55ecf7bf4e633d7d2fe16ab0ed3cb881546c /meta/recipes-graphics/wayland/weston_1.8.0.bb
parentedb240b43f382f68206397c6e7c7d791b89e3da4 (diff)
downloadpoky-3ff474c64235579316c6fe104fd61af90062ac65.tar.gz
weston: Upgrade weston_1.6.0.bb -> weston_1.8.0.bb
Make error() portable, Fix build on musl copyright year changed for weston compositor.c - * Copyright © 2012 Collabora, Ltd. + * Copyright © 2012-2015 Collabora, Ltd. (From OE-Core rev: 4f401540b2055fd6fb8a5edac6811199379dba90) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.8.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/weston_1.8.0.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.8.0.bb b/meta/recipes-graphics/wayland/weston_1.8.0.bb
new file mode 100644
index 0000000000..ac6bd9784b
--- /dev/null
+++ b/meta/recipes-graphics/wayland/weston_1.8.0.bb
@@ -0,0 +1,93 @@
1SUMMARY = "Weston, a Wayland compositor"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \
6 file://src/compositor.c;endline=23;md5=a9793f1edc8d1a4c344ca8ae252352fb"
7
8SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
9 file://weston.png \
10 file://weston.desktop \
11 file://make-lcms-explicitly-configurable.patch \
12 file://make-libwebp-explicitly-configurable.patch \
13 file://0001-make-error-portable.patch \
14"
15SRC_URI[md5sum] = "24cb8a7ed0535b4fc3642643988dab36"
16SRC_URI[sha256sum] = "8963e69f328e815cec42c58046c4af721476c7541bb7d9edc71740fada5ad312"
17
18inherit autotools pkgconfig useradd
19
20DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg"
21DEPENDS += "wayland libinput virtual/egl pango"
22
23EXTRA_OECONF = "--enable-setuid-install \
24 --disable-xwayland \
25 --enable-simple-clients \
26 --enable-clients \
27 --enable-demo-clients-install \
28 --disable-rpi-compositor \
29 --disable-rdp-compositor \
30 "
31
32EXTRA_OECONF_append_qemux86 = "\
33 WESTON_NATIVE_BACKEND=fbdev-backend.so \
34 "
35EXTRA_OECONF_append_qemux86-64 = "\
36 WESTON_NATIVE_BACKEND=fbdev-backend.so \
37 "
38PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \
41 "
42#
43# Compositor choices
44#
45# Weston on KMS
46PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev"
47# Weston on Wayland (nested Weston)
48PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa"
49# Weston on X11
50PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo"
51# Headless Weston
52PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor"
53# Weston on framebuffer
54PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev"
55# weston-launch
56PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam drm"
57# VA-API desktop recorder
58PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva"
59# Weston with EGL support
60PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl"
61# Weston with cairo glesv2 support
62PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo"
63# Weston with lcms support
64PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms"
65# Weston with webp support
66PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp"
67# Weston with unwinding support
68PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
69
70do_install_append() {
71 # Weston doesn't need the .la files to load modules, so wipe them
72 rm -f ${D}/${libdir}/weston/*.la
73
74 # If X11, ship a desktop file to launch it
75 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "x11" ]; then
76 install -d ${D}${datadir}/applications
77 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
78
79 install -d ${D}${datadir}/icons/hicolor/48x48/apps
80 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
81 fi
82}
83
84PACKAGES += "${PN}-examples"
85
86FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}"
87FILES_${PN}-examples = "${bindir}/*"
88
89RDEPENDS_${PN} += "xkeyboard-config"
90RRECOMMENDS_${PN} = "liberation-fonts"
91
92USERADD_PACKAGES = "${PN}"
93GROUPADD_PARAM_${PN} = "--system weston-launch"