diff options
author | Ross Burton <ross.burton@intel.com> | 2013-11-26 17:33:43 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-11-29 09:52:57 +0000 |
commit | 75cc5321dbea866b886fd73b33619b20d9253344 (patch) | |
tree | fff65bc8739680a93ae456952a450a98c05f88e1 /meta/recipes-graphics/wayland/weston_1.3.0.bb | |
parent | 6fcb96076ca60ef30062fda0ff8308cc840ab07d (diff) | |
download | poky-75cc5321dbea866b886fd73b33619b20d9253344.tar.gz |
weston: upgrade to 1.3.1
(From OE-Core rev: 4a9f855ecb209aebe37f9a26f3f4129a570a3af4)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.3.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_1.3.0.bb | 79 |
1 files changed, 0 insertions, 79 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.3.0.bb b/meta/recipes-graphics/wayland/weston_1.3.0.bb deleted file mode 100644 index 7a0b3f9ac9..0000000000 --- a/meta/recipes-graphics/wayland/weston_1.3.0.bb +++ /dev/null | |||
@@ -1,79 +0,0 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=275efac2559a224527bd4fd593d38466 \ | ||
6 | file://src/compositor.c;endline=23;md5=aa98a8db03480fe7d500d0b1f4b8850c" | ||
7 | |||
8 | SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://weston.png \ | ||
10 | file://weston.desktop" | ||
11 | SRC_URI[md5sum] = "29ad994dd5ea07f52d7bffb24c25d9f7" | ||
12 | SRC_URI[sha256sum] = "8e4f5b4736358b63d83c3252567ba7aa49cc0da9e2e2c30f59ddf635159702a0" | ||
13 | |||
14 | |||
15 | inherit autotools pkgconfig useradd | ||
16 | |||
17 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
18 | DEPENDS += "wayland virtual/mesa virtual/egl pango" | ||
19 | |||
20 | EXTRA_OECONF = "--enable-setuid-install \ | ||
21 | --disable-tablet-shell \ | ||
22 | --disable-xwayland \ | ||
23 | --enable-simple-clients \ | ||
24 | --enable-clients \ | ||
25 | --enable-demo-clients \ | ||
26 | --disable-simple-egl-clients \ | ||
27 | --disable-libunwind \ | ||
28 | --disable-rpi-compositor \ | ||
29 | --disable-rdp-compositor" | ||
30 | |||
31 | |||
32 | PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'wayland', 'kms wayland', '', d)} \ | ||
33 | ${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ | ||
34 | ${@base_contains('DISTRO_FEATURES', 'pam', 'launch', '', d)} \ | ||
35 | " | ||
36 | # | ||
37 | # Compositor choices | ||
38 | # | ||
39 | # Weston on KMS | ||
40 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev mesa mtdev" | ||
41 | # Weston on Wayland (nested Weston) | ||
42 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,mesa" | ||
43 | # Weston on X11 | ||
44 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
45 | # Headless Weston | ||
46 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
47 | # Weston on framebuffer | ||
48 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
49 | # weston-launch | ||
50 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,libpam" | ||
51 | # VA-API desktop recorder | ||
52 | PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva" | ||
53 | |||
54 | do_install_append() { | ||
55 | # Weston doesn't need the .la files to load modules, so wipe them | ||
56 | rm -f ${D}/${libdir}/weston/*.la | ||
57 | |||
58 | for feature in ${DISTRO_FEATURES}; do | ||
59 | # If X11, ship a desktop file to launch it | ||
60 | if [ "$feature" = "x11" ]; then | ||
61 | install -d ${D}${datadir}/applications | ||
62 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
63 | |||
64 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
65 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
66 | fi | ||
67 | done | ||
68 | } | ||
69 | |||
70 | PACKAGES += "${PN}-examples" | ||
71 | |||
72 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${datadir}" | ||
73 | FILES_${PN}-examples = "${bindir}/*" | ||
74 | |||
75 | RDEPENDS_${PN} += "xkeyboard-config" | ||
76 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
77 | |||
78 | USERADD_PACKAGES = "${PN}" | ||
79 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||