diff options
author | Jussi Kukkonen <jussi.kukkonen@intel.com> | 2016-07-15 11:07:31 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-07-20 10:28:52 +0100 |
commit | a5392dd424f16d25513600bff13d635cf870265d (patch) | |
tree | ae8df1352dfae46a577080507f0433a8ed49992e /meta/recipes-graphics/wayland/weston_1.11.0.bb | |
parent | ddb0de65085f196ebf83c71d23b6ff4ac5f0bc76 (diff) | |
download | poky-a5392dd424f16d25513600bff13d635cf870265d.tar.gz |
weston: Upgrade 1.10.0 -> 1.11.0
Remove now unnecessary patch, rebase others.
Add musl build fix patch.
(From OE-Core rev: f915e81336a63331bc6e4b920089d1495ae7f63f)
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/weston_1.11.0.bb')
-rw-r--r-- | meta/recipes-graphics/wayland/weston_1.11.0.bb | 117 |
1 files changed, 117 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/weston_1.11.0.bb b/meta/recipes-graphics/wayland/weston_1.11.0.bb new file mode 100644 index 0000000000..3ad309dab6 --- /dev/null +++ b/meta/recipes-graphics/wayland/weston_1.11.0.bb | |||
@@ -0,0 +1,117 @@ | |||
1 | SUMMARY = "Weston, a Wayland compositor" | ||
2 | DESCRIPTION = "Weston is the reference implementation of a Wayland compositor" | ||
3 | HOMEPAGE = "http://wayland.freedesktop.org" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \ | ||
6 | file://src/compositor.c;endline=23;md5=1d535fed266cf39f6d8c0647f52ac331" | ||
7 | |||
8 | SRC_URI = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \ | ||
9 | file://weston.png \ | ||
10 | file://weston.desktop \ | ||
11 | file://0001-make-error-portable.patch \ | ||
12 | file://0001-configure.ac-Fix-wayland-protocols-path.patch \ | ||
13 | file://0001-shared-include-stdint.h-for-int32_t.patch \ | ||
14 | file://xwayland.weston-start \ | ||
15 | file://make-weston-launch-exit-for-unrecognized-option.patch \ | ||
16 | file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ | ||
17 | " | ||
18 | SRC_URI[md5sum] = "bc6f90a2039163804aecfa663b69c4c2" | ||
19 | SRC_URI[sha256sum] = "05e086e9f186a06843b9f7a5e1abf19347b1a6e4be26d7e74927abc17b6b7125" | ||
20 | |||
21 | inherit autotools pkgconfig useradd distro_features_check | ||
22 | # depends on virtual/egl | ||
23 | REQUIRED_DISTRO_FEATURES = "opengl" | ||
24 | |||
25 | DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0 jpeg" | ||
26 | DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native" | ||
27 | |||
28 | EXTRA_OECONF = "--enable-setuid-install \ | ||
29 | --disable-rpi-compositor \ | ||
30 | --disable-rdp-compositor \ | ||
31 | WAYLAND_PROTOCOLS_SYSROOT_DIR=${STAGING_DIR}/${MACHINE} \ | ||
32 | " | ||
33 | EXTRA_OECONF[vardepsexclude] = "MACHINE" | ||
34 | |||
35 | EXTRA_OECONF_append_qemux86 = "\ | ||
36 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
37 | " | ||
38 | EXTRA_OECONF_append_qemux86-64 = "\ | ||
39 | WESTON_NATIVE_BACKEND=fbdev-backend.so \ | ||
40 | " | ||
41 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms fbdev wayland egl', '', d)} \ | ||
42 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)} \ | ||
43 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \ | ||
44 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ | ||
45 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ | ||
46 | clients launch" | ||
47 | # | ||
48 | # Compositor choices | ||
49 | # | ||
50 | # Weston on KMS | ||
51 | PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev virtual/mesa mtdev" | ||
52 | # Weston on Wayland (nested Weston) | ||
53 | PACKAGECONFIG[wayland] = "--enable-wayland-compositor,--disable-wayland-compositor,virtual/mesa" | ||
54 | # Weston on X11 | ||
55 | PACKAGECONFIG[x11] = "--enable-x11-compositor,--disable-x11-compositor,virtual/libx11 libxcb libxcb libxcursor cairo" | ||
56 | # Headless Weston | ||
57 | PACKAGECONFIG[headless] = "--enable-headless-compositor,--disable-headless-compositor" | ||
58 | # Weston on framebuffer | ||
59 | PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor,--disable-fbdev-compositor,udev mtdev" | ||
60 | # weston-launch | ||
61 | PACKAGECONFIG[launch] = "--enable-weston-launch,--disable-weston-launch,drm" | ||
62 | # VA-API desktop recorder | ||
63 | PACKAGECONFIG[vaapi] = "--enable-vaapi-recorder,--disable-vaapi-recorder,libva" | ||
64 | # Weston with EGL support | ||
65 | PACKAGECONFIG[egl] = "--enable-egl --enable-simple-egl-clients,--disable-egl --disable-simple-egl-clients,virtual/egl" | ||
66 | # Weston with cairo glesv2 support | ||
67 | PACKAGECONFIG[cairo-glesv2] = "--with-cairo-glesv2,--with-cairo=image,cairo" | ||
68 | # Weston with lcms support | ||
69 | PACKAGECONFIG[lcms] = "--enable-lcms,--disable-lcms,lcms" | ||
70 | # Weston with webp support | ||
71 | PACKAGECONFIG[webp] = "--with-webp,--without-webp,libwebp" | ||
72 | # Weston with unwinding support | ||
73 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" | ||
74 | # Weston with systemd-login support | ||
75 | PACKAGECONFIG[systemd] = "--enable-systemd-login,--disable-systemd-login,systemd dbus" | ||
76 | # Weston with Xwayland support (requires X11 and Wayland) | ||
77 | PACKAGECONFIG[xwayland] = "--enable-xwayland,--disable-xwayland" | ||
78 | # colord CMS support | ||
79 | PACKAGECONFIG[colord] = "--enable-colord,--disable-colord,colord" | ||
80 | # Clients support | ||
81 | PACKAGECONFIG[clients] = "--enable-clients --enable-simple-clients --enable-demo-clients-install,--disable-clients --disable-simple-clients" | ||
82 | # Weston with PAM support | ||
83 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" | ||
84 | |||
85 | do_install_append() { | ||
86 | # Weston doesn't need the .la files to load modules, so wipe them | ||
87 | rm -f ${D}/${libdir}/weston/*.la | ||
88 | |||
89 | # If X11, ship a desktop file to launch it | ||
90 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "x11" ]; then | ||
91 | install -d ${D}${datadir}/applications | ||
92 | install ${WORKDIR}/weston.desktop ${D}${datadir}/applications | ||
93 | |||
94 | install -d ${D}${datadir}/icons/hicolor/48x48/apps | ||
95 | install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps | ||
96 | fi | ||
97 | |||
98 | if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then | ||
99 | install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland | ||
100 | fi | ||
101 | } | ||
102 | |||
103 | PACKAGE_BEFORE_PN += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)}" | ||
104 | PACKAGES += "${PN}-examples" | ||
105 | |||
106 | FILES_${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so ${datadir}" | ||
107 | FILES_${PN}-examples = "${bindir}/*" | ||
108 | |||
109 | FILES_${PN}-xwayland = "${libdir}/${BPN}/xwayland.so" | ||
110 | RDEPENDS_${PN}-xwayland += "xserver-xorg-xwayland" | ||
111 | |||
112 | RDEPENDS_${PN} += "xkeyboard-config" | ||
113 | RRECOMMENDS_${PN} = "liberation-fonts" | ||
114 | RRECOMMENDS_${PN}-dev += "wayland-protocols" | ||
115 | |||
116 | USERADD_PACKAGES = "${PN}" | ||
117 | GROUPADD_PARAM_${PN} = "--system weston-launch" | ||